Since upgrading to 2019.3, the Open Project button causes Windows to BSOD

I am running Windows 10 1903 (18362.476). When I click the "Open..." button in PhpStorm, the dialog box appears but it doesn't show any folders to select from. It pauses as though it's loading the directory structure, then I get a BSOD with the error code "KERNEL MODE HEAP CORRUPTION". I have been able to replicate this twice in a row.

18 comments
Comment actions Permalink

Try disabling these three at Help | Find Action | Registry: http://prntscr.com/rb0poi

1
Comment actions Permalink

Eugene's fix worked for me

1
Comment actions Permalink

I've had the exact same issue, BSOD and KERNEL_MODE_HEAP_CORRUPTION included, and Eugene's fix worked for me as well. It would be worth being looked into.

1
Comment actions Permalink

AmiWallonBitume What kind of hardware are you running? Is it an HP laptop?

1
Comment actions Permalink

Ju, it's a Dell Inspiron 5755.

1
Comment actions Permalink

This still hasn't been fixed in 2020.1.2

1
Comment actions Permalink

Probably, there's something wrong with one of your device drivers. It's hard to say with which one exactly without looking at the BSOD minidump.

0
Comment actions Permalink

I am having the same issue. Replicated multiple times with the same error code. Windows 10.0.18363 Build 18363

0
Comment actions Permalink

It seems to be related to WSL and Windows 10 1903. That was the version of Windows I had when this problem started. I recently borrowed a computer with Windows 10 1903, installed WSL and PhpStorm and it didn't take long for the issue to appear there as well. I then disabled WSL and the issue went away. I've since upgraded my own computer to Windows 10 1909, so we'll see if the problem persists. Still, this is the only program I have with this problem. It can't just be WSL to blame, there has to be something about PhpStorm that is unique that causes an issue when combined with WSL. If I had to guess, I would say it's somehow related to the fact that PhpStorm does not use the native Windows file explorer dialog (no doubt this is because it's based on Java). Every other program I have uses the native file explorer dialog and there's no issue. Also, in no other program do I get significant delays when the file explorer dialog loads because the program is scanning the directories.

0
Comment actions Permalink

I recently had to reinstall Windows on my computer. I reinstalled WSL and PhpStorm, and so far have had no issues. Still, out of precaution I followed the advice of the comment above.

0
Comment actions Permalink

I confirm I have a similar problem and switched Registry options like Eugene Morozov fix. Running on Dell Inspiron 3493 don't know if the laptop's 8GB of RAM and multiple files of Chrome is the problem on this. Maybe Web Development on IntelliJ + Chrome + Win10 demands 16GB to run smoothly.. 

0
Comment actions Permalink

Georgiogeo27 I have 32GB on my dev machine and still had the same issue

0
Comment actions Permalink

Ju well my friends I really don't know how to fix this. Tried this though which gives some great tips on Faster Program Switching, Power-Saving Mode (which I don't like since it disables my annotations styling) and the most important to unload heavy load by disabling unused Plugins! 

While new BSOD haven't occured and I 've checked for driver updates IntelliJ still crashes from time to time. Guess is a very over-engineered product that works continuously and is very CPU and RAM intensive. The thing is I don't have an independent GPU so that may cause problems

My full Laptop specs here:

DELL 3493

  • Intel Core i5 - 1035G1 CPU @ 1.00 GHz
  • 8GB RAM (soon to be upgraded to 16 GB)
  • Windows 10 Home
  • Intel UHD Graphics 
  • TOSHIBA SSD NVMe 512 GB + SSD HyperX 256 GB with plenty of GB to mess around 

When I get my RAM upgraded I will post results here.

Keep coding!

0
Comment actions Permalink

It doesn't appear something we can fix on our side - the issue is considered to be third-party: https://youtrack.jetbrains.com/issue/IDEA-232194

0
Comment actions Permalink

Thanks for the quick reply Eugene. The link you provided doesn't work for me. If it is considered to be third-party, does this mean it could be caused by a plugin? If so, has it been identified?

0
Comment actions Permalink

My apologies, the issue had limited visibility, fixed now.

If it is considered to be third-party, does this mean it could be caused by a plugin?

No, it seems that Windows itself is considered to be the culprit here.

0
Comment actions Permalink

I 've working heavily during Coronavirus using my laptop (specs on previous comment) but when I started using the office pc (similar specwise) the shutdown problem didn't occur. So I think that the DELL laptop somehow turns off Intellij when it heats too much.. also as it gets heated closes the program more recently. Guess tower solution is better for summer programming but can anyone confirm this?

0
Comment actions Permalink

I also have the issue and investigated about it.
on my tests,I am using windows 10 1909
It is related to the wsl p9 support.

  • Intellij 2020.1.3
  • when in the intellij registry the line: wsl.p9.show.roots.in.file.chooser is checked
  • when you don't have any wsl distribution running the path \wsl$\ should be shown as empty (this is what is show on windows explorer and with totalcommander)
    (can be checked by executing "wsl -l" in command line)
  • when you never opened a file chooser while wsl was running (so there is no \wsl$\ entry in the file chooser root)

if you are in this state trying to open any file chooser (open project, add JDK in SDKs list,...)

if you have a running wsl distribution this issue won't occure.

once again the issue only occurs with intellij. windows explorer, totalcommander of other file system browsers I tried dont make any issue.

@...
hi
as you answered in the support post i am mentionning you here.

can you please take a look as we have now a simple direction. I think it may be related to the JVM Intellij is using (as it is jetbrain implementation)
for me it is JBR-11.0.7.10-765.64-jfx

0

Please sign in to leave a comment.