2019.3 Update disabled Fcitx input? - Ubuntu

Answered

Hi,

I was using Clion 2019.2 using Fcitx as my input method on my Ubuntu machine. Everything worked fine and I could use Ctrl+Shift (hotkey set in Fcitx) to switch b/w input methods.

However, after I updated to 2019.3, Fcitx stopped working in Clion (can't switch to other input methods, stuck on default one). Does anyone have any ideas?

Thanks!

10 comments
Comment actions Permalink

I have the same problem with you! If you have any reslove method, pls tell me. Thx!

我和你有相同的问题, 如果你有任何解决办法, 请告诉我~

BTW, 我的环境是Ubuntu16.04, 输入法为: sougou(fcitx)

0
Comment actions Permalink

Sorry for the inconvenience.

It seems to be https://youtrack.jetbrains.com/issue/IDEA-227895. Feel free to comment or upvote the issue in order to get updates. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

2
Comment actions Permalink

same problem here. 

I'm using Ubuntu 18.04 LTS.

0
Comment actions Permalink

一样的问题,有没有什么办法。

0
Comment actions Permalink

same issue

0
Comment actions Permalink

 

我尝试修改输入法配置,然后就可以了,工作非常OK,怀疑是Ubuntu 系统升级导致配置重置,尝试修改一些配置触发配置更新重写~

0
Comment actions Permalink

Seems the problem was caused from the jbr delivered with the new version. I have tried to set IDEA_JDK pointed to a earlier version of oracle jdk 11(build 11+28, and 11.05 +10-LTS), the fcitx support is back again.

Although the Chinese input method is back , but the font display effects is much more worse than the bundled jvm.

0
Comment actions Permalink

俺也是,脑阔阔疼

0
Comment actions Permalink

Hello everyone!

Please use the following VM option -Dauto.disable.input.methods=false (https://intellij-support.jetbrains.com/hc/en-us/articles/206544869-Configuring-JVM-options-and-platform-properties) to resolve the problem.

5
Comment actions Permalink

Anna Falevskaya Thank you ! It works fine.

0

Please sign in to leave a comment.