Cannot switch project windows on Mac using ⌘ + ` (command + back tick)

Answered

I'm not sure if this is due to my recent update to macOS Catalina, but I noticed that the ⌘ + ` shortcut keys for switching between app windows on Mac doesn't work for my JetBrains IDEs (I've only tried with IntelliJ and PyCharm so far) anymore. I've already checked if there's anything on the keymap that somehow overrides it, but there isn't. Any ideas?

17 comments
Comment actions Permalink

Do you have "Activate next window" action assigned to the CMD+` shortcut? 

https://i.imgur.com/y1x2Efh.png

6
Comment actions Permalink

I didn't and that's strange. Has this been changed recently through an update? It used to work without me having to set it.

Setting the keyboard shortcut solves this issue for me. Thanks!

0
Comment actions Permalink

Ok, I've just upgraded to 2019.3 and the IDE is again behaving erratically. I can confirm that  ⌘ + ` is set to "Activate next window" action, and it works when I open new projects within the current session. However, once I quit the application and restart, the shortcut no longer works. When I try switching through the Window menu (Window > [project name]), I can go back to the previously focused project using the shortcut. However, from there I can't switch back to the other project using the same shortcut.

0
Comment actions Permalink

Can you record a short video demonstrating the problem with the "Presentation assistant" plugin enabled? 

 

0
Comment actions Permalink

I have the exact same issue. Tried to first remove the shortcut, then restarted IDE, window switching didn't work, then I added this shortcut again, again didn't work. Then I added a second keystroke, also didn't work.

It seems to work only once, after the editor gets focus the shortcut no longer works.

Now i reverted to 2019.2 and everything is working as expected. This is kinda frustrating for me, as I have 2 projects open all the time :/

0
Comment actions Permalink

@rd

Please report a bug at https://youtrack.jetbrains.com/issues/IDEA and attach a short video demonstrating the problem with the "Presentation assistant" plugin enabled as well as idea.log 

0
Comment actions Permalink

Same issue after update. Working on Mac and I have the shorcut "Activate next window" assigned to ⌘ + ` but it stopped working recently.

0
Comment actions Permalink

Hello everyone,

If you have Cmd-` assigned to "Activate Next Window", then likely you are facing one of the following issues:

https://youtrack.jetbrains.com/issue/IDEA-225027

https://youtrack.jetbrains.com/issue/IDEA-224411

Both of them are fixed, the fix will be delivered in version 2019.3.1.

Another known issue you may face is related to keyboard layouts: https://youtrack.jetbrains.com/issue/JBR-1688

0
Comment actions Permalink

I thought I had the the same issue as my shortcut seemed to randomly not work.

And I found the issue: when the terminal inside Pycharm is in focus, those shortcuts no longer work! As I often use the terminal it would be nice if I could still be able to use those shortcuts without having to unfocus the terminal. Any idea on how to achieve that?

Thanks!

0
Comment actions Permalink

rafali

Could not reproduce that. Do you have any action except "Activate Next Window" assigned to "Cmd+`" shortcut? You can check that under "Preferences | Keymap > Find shortcut"

0
Comment actions Permalink

Thanks for the reply. I assigned it on "Cmd+@" (french azerty apple keyboard) and it's the only assignment.

And it only fails to work when the Pycharm Terminal is in focus.

1
Comment actions Permalink

I found the issue: the option "Override IDE shortcuts" was activated by default!
When disabled, everything is working as I expected 👍🏾

3
Comment actions Permalink

rafali

It works for me! thanks.

0
Comment actions Permalink

what does the activate next window suppose to be doing?

0
Comment actions Permalink

Miranda9

When you have multiple IDE project windows open, it switches to the next window/project.

0
Comment actions Permalink

Try editing the keyboard shortcut for "Activate next window" (as per Konstantin Annikov above) and adding your keystroke as a second stroke.

I found that the default setting was using the "wrong" apostrophe:

0

Please sign in to leave a comment.