Cannot switch project windows on Mac using ⌘ + ` (command + back tick)

Answered

I'm not sure if this is due to my recent update to macOS Catalina, but I noticed that the ⌘ + ` shortcut keys for switching between app windows on Mac doesn't work for my JetBrains IDEs (I've only tried with IntelliJ and PyCharm so far) anymore. I've already checked if there's anything on the keymap that somehow overrides it, but there isn't. Any ideas?

7
24 comments

Do you have "Activate next window" action assigned to the CMD+` shortcut? 

https://i.imgur.com/y1x2Efh.png

10

I didn't and that's strange. Has this been changed recently through an update? It used to work without me having to set it.

Setting the keyboard shortcut solves this issue for me. Thanks!

0

Ok, I've just upgraded to 2019.3 and the IDE is again behaving erratically. I can confirm that  ⌘ + ` is set to "Activate next window" action, and it works when I open new projects within the current session. However, once I quit the application and restart, the shortcut no longer works. When I try switching through the Window menu (Window > [project name]), I can go back to the previously focused project using the shortcut. However, from there I can't switch back to the other project using the same shortcut.

0

Can you record a short video demonstrating the problem with the "Presentation assistant" plugin enabled? 

 

0

I have the exact same issue. Tried to first remove the shortcut, then restarted IDE, window switching didn't work, then I added this shortcut again, again didn't work. Then I added a second keystroke, also didn't work.

It seems to work only once, after the editor gets focus the shortcut no longer works.

Now i reverted to 2019.2 and everything is working as expected. This is kinda frustrating for me, as I have 2 projects open all the time :/

0

@rd

Please report a bug at https://youtrack.jetbrains.com/issues/IDEA and attach a short video demonstrating the problem with the "Presentation assistant" plugin enabled as well as idea.log 

0

Same issue after update. Working on Mac and I have the shorcut "Activate next window" assigned to ⌘ + ` but it stopped working recently.

0

Hello everyone,

If you have Cmd-` assigned to "Activate Next Window", then likely you are facing one of the following issues:

https://youtrack.jetbrains.com/issue/IDEA-225027

https://youtrack.jetbrains.com/issue/IDEA-224411

Both of them are fixed, the fix will be delivered in version 2019.3.1.

Another known issue you may face is related to keyboard layouts: https://youtrack.jetbrains.com/issue/JBR-1688

0

I thought I had the the same issue as my shortcut seemed to randomly not work.

And I found the issue: when the terminal inside Pycharm is in focus, those shortcuts no longer work! As I often use the terminal it would be nice if I could still be able to use those shortcuts without having to unfocus the terminal. Any idea on how to achieve that?

Thanks!

0

rafali

Could not reproduce that. Do you have any action except "Activate Next Window" assigned to "Cmd+`" shortcut? You can check that under "Preferences | Keymap > Find shortcut"

0

Thanks for the reply. I assigned it on "Cmd+@" (french azerty apple keyboard) and it's the only assignment.

And it only fails to work when the Pycharm Terminal is in focus.

1

I found the issue: the option "Override IDE shortcuts" was activated by default!
When disabled, everything is working as I expected 👍🏾

4

rafali

It works for me! thanks.

0

what does the activate next window suppose to be doing?

0

Miranda9

When you have multiple IDE project windows open, it switches to the next window/project.

0

Try editing the keyboard shortcut for "Activate next window" (as per Konstantin Annikov above) and adding your keystroke as a second stroke.

I found that the default setting was using the "wrong" apostrophe:

2

I have the same issue on CLion(the version is 2021.2). Using "Command + `" cannot always switch between windows, but sometimes it did(The shortcut is set correctly and the windows are not in full screen mode). For instance, I have two windows and both opened some files, I can switch from 1 to 2, but I can't switch back. That is, I can only switch from one direction. But using "Command + Shift + `" is OKAY, I can switch back and forth. Actually there are times that I can switch successfully back and forth among multiple projects. So, I guess the problem is still there.

Now there's a common way I used to avoid this, I will maximize a window before open a new project, and then I open that new project in "New Window", and the two projects become tabs in one fullscreen window. This works just fine.

0

Is it reproducible with newer IDE version?

0

I don't know. I think this is tolerable and I'm too lazy to update it.

0

I faced the same issue on Webstorm 2023.1.

The way I solved:

  • I remove the shortcut for Activate Next Window
  • I re-add the shortcut, hitting: Cmd+`

One thing I noticed, the value "⌘ + `" has been replaced by "⌘Dead Grave" .

I hope it helps.

 

3

Mathieu Benard thank you, this works! 

I can confirm that this bug occurs in PyCharm 2023.1.4. 

This was driving me crazy. Cmd+` stopped working out of the blue. 

What the hell is "Dead Grave"? 

0

Nurlan, could you please specify which keyboard layout you use? Usually, a similar problem occurs when the AZERTY or other layouts are used because the platform doesn't support national layouts properly.

0

I had the same issue in MacOS and for me it was because the project windows were not “merged”.
So the solution was : Go to Window | Merge All Project Windows  

> On macOS, you can merge all opened project windows into one, turning them into tabs. Make sure that there are several PyCharm projects opened in separate windows. Go to Window | Merge All Project Windows.

https://www.jetbrains.com/help/pycharm/open-projects.html#c991caf4

0

Please sign in to leave a comment.