CLion fails to update to 2019.3 due to missing 7zip.exe in Jetbrains/Toolbox/bin folder

Answered

I've been trying to get CLion updated for several tries now and it keeps failing with the message: "Failed to extract package.  Failed to find 7zip executable in the package atC:/Users/(myusername)/AppData/Local/Jetbrains/Toolbox/bin/7z.exe  (notice the lack of space between "at" and "C/Users..." in the message.)

This is odd because I have had great success with JetBrains Toolbox installing many different "Tools" updates on this machine for over a year (Including Rider, DataGrip, PyCharm Edu, PyCharm Professional, WebStorm, and IntelliJ IDEA)

This is on Windows 10 (Version 1909 (OS Build 18363.476)).
Toolbox version: Toolbox App 1.16.6067, OS kernel winnt 10.0.18363 on x86_64

As a workaround, I went out and installed 7-zip from its website, and copied 7z.exe from C:\Program Files (x86)\7-Zip
to the folder it complained about: C:\Users\(myusername)\AppData\Local\JetBrains\Toolbox\bin\ and ran the update again.

This worked, but this was a manual workaround.  When I tried to update the Toolbox itself, only the 4 apps had updates (so no way to "fix" Toolbox to cover this issue). 

Would it be possible for Toolbox to run a check of 3rd party tools it is using for install and update/install them if they are missing?  I did not, of course, remove 7zip.exe from that folder at any point, so the flaw is obvious.  Thanks!!!  

1 comment
Comment actions Permalink

Hi Patrick,

Sorry for the inconvenience. We have a related issue in our tracker: https://youtrack.jetbrains.com/issue/TBX-3844. Could you please attach your Toolbox App logs (сlick the metal nut icon on the right-hand side of the Toolbox App | Show Log file) there?

0

Please sign in to leave a comment.