Run Django Test (docker-compose run) WITHOUT --no-deps option

Hi,

 

How I can DISABLE --no-deps on docker-compose run, when I run Django Test?

 

Thanks a lot,

4 comments
Comment actions Permalink

Hi,

PyCharm, in fact, doesn't support this option at the moment https://youtrack.jetbrains.com/issue/PY-37647

Not sure why you have it in the first place. Could you share a screenshot of your run configuration and another one showing this option when running tests?

0
Comment actions Permalink

Hi Sergey,

 

Thanks for your fast answer....

 

This is my config:

 

 

And YES, the idea is NOT USES the --no-deps when uses docker-compose run

 

The option PyCharm put this one automatic (see the screenshoot):

 

 

Thanks a lot,

0
Comment actions Permalink

Oh, I see, it is added automatically if you add run command to your run configuration. So I guess the workaround is to not use run.

0
Comment actions Permalink

Hi Sergey,

 

The detailt is I need use the run option because I need the containers create and destroy when the test are finished.

0

Please sign in to leave a comment.