Very slow table view in DataGrip


Using datagrip 2019.3, but tried 2018.* too -- same issue


I've also tried runtime switcher to use Java11. Still same issue


I also don't understand why if I add to VM options


it doesn't work as if this argument was ignored..


Here's how activity monitor looks like when I scroll through SQL table view (ca 300 rows only, but this happens on any table view)


%CPU Subsystem

112.0 <Process total CPU usage>
96.3 <infrastructure: Java2D Queue Flusher>
3.6 <JIT compiler>
1.7 <infrastructure: AWT-AppKit>
1.6 <unidentified: Java2D Queue Flusher>
1.3 <Activity Monitor>
1.1 <unidentified: UI thread>
0.7 editor.actions (in com.intellij.openapi)


=== About ===
Build version: DataGrip 2019.3.1 Build #DB-193.5662.58 December 18, 2019
Java version: 1.8.0_232-release-1638-b6x86_64
Operating System: Mac OS X (10.13.6, x86_64)
JVM version: OpenJDK 64-Bit Server VM JetBrains s.r.o

=== System ===
Number of CPU: 24
Used memory: 322Mb
Free memory: 632Mb
Total memory: 955Mb
Maximum available memory: 1979Mb

=== Displays ===
Display 0: 2560x1440; scale: 1.00

=== Plugins ===
Custom plugins: []
Disabled plugins:[]


Comment actions Permalink

Hello Mikl0005, Levelworm
Sorry for slow response

The issue might be related to

It would be very helpful if you can capture a performance snapshot using this instruction (Capture CPU Snapshot section) and send it to me or attach it to existing or new issue here:

Comment actions Permalink

Hi do you know where we can file bugs? I think it would be quicker than asking questions here.


Please sign in to leave a comment.