Find in Path is not working


I am using RubyMine 2019.3.1 on mac

I am using cmd + shift + F to find in path.

I write the text to find ( in whole project) and there are no results.

I tried <File | Invalidate Caches/Restart.. | Invalidate and Restart >, but no effect.

Comment actions Permalink

I tried reinstall but no effect.

keymap Declaration or Usages and Implementation(s) is not working.

Comment actions Permalink


does it happen in all your projects or only certain ones? Does the search work for another files (in case you create a new file and add some code there)?

Comment actions Permalink

all project.

new file has not working.

Comment actions Permalink

Would it be possible to check also with a new project? In case the problem persists please attach idea.log (Help - Show log in) You can send it also to

Comment actions Permalink

ok. i have sent.

Comment actions Permalink

Does this issue has fixed?

I have the same issue!

Comment actions Permalink

You can try removing .idea folder from the project in question (while IDE is closed) and reopening it in RubyMinem.This is the method provided by Olga Kuvardina

Comment actions Permalink

I'm not sure this is a bug or not, but I need to "Invalidate cache and restart" to fix this

Comment actions Permalink

I was in a situation where *nothing* could be found using this dialog. It just suddently happened in Intellij 2019.3 .  I went to the dialog box and tried different things. Then what I found is that the Dirctory entry was incorrectly set: it was not in the  Project directory but somewhere under Applications.

I then pasted in the root of the project directory and voila'   Find in Path is working again.




Comment actions Permalink

If it can help, I have it too under IJ ultimate EA (2020.2 Beta).

A possible source of the problem is that I copy-pasted an existing folder to create my project. Hower I noticed that typing only the 5 first characters *does work*:

6 does not:

Comment actions Permalink

Same here. Just moved to 2020.2 and Find in Path does not display results after the 5th letter.


Edit: Seems to be an indexing issue. Invalidating Intellij's caches resolves the issue for now.


2020-07-30 09:53:50,827 [87156483] ERROR - llij.ide.plugins.PluginManager - null
at com.intellij.util.indexing.containers.IdBitSet.nextSetBit(
at com.intellij.util.indexing.containers.IdBitSet.access$100(
at com.intellij.util.indexing.containers.IdBitSet$Iterator.<init>(
at com.intellij.util.indexing.containers.IdBitSet$Iterator.<init>(
at com.intellij.util.indexing.containers.IdBitSet.intIterator(
at com.intellij.util.indexing.containers.ChangeBufferingList.intIterator(
at com.intellij.util.indexing.impl.ValueContainerImpl.getIntIteratorOutOfFileSetObject(
at com.intellij.util.indexing.impl.ValueContainerImpl.access$200(
at com.intellij.util.indexing.impl.ValueContainerImpl$1.getInputIdsIterator(
at com.intellij.util.indexing.impl.MergedValueContainer$1.getInputIdsIterator(
at com.intellij.util.indexing.InvertedIndexUtil.collectInputIdsContainingAllKeys(
at com.intellij.util.indexing.FileBasedIndexEx.lambda$collectFileIdsContainingAllKeys$13(
at com.intellij.util.indexing.FileBasedIndexEx.lambda$processExceptions$4(
at com.intellij.util.ConcurrencyUtil.withLock(
at com.intellij.util.indexing.FileBasedIndexEx.lambda$processExceptions$5(
at com.intellij.util.indexing.IndexAccessValidator.validate(
at com.intellij.util.indexing.FileBasedIndexEx.processExceptions(
at com.intellij.util.indexing.FileBasedIndexEx.collectFileIdsContainingAllKeys(
at com.intellij.util.indexing.FileBasedIndexEx.processFilesContainingAllKeys(
at com.intellij.util.indexing.FileBasedIndexEx.getFilesWithKey(
at com.intellij.find.impl.IdeaIndexBasedFindInProjectSearchEngine$MyFindInProjectSearcher.lambda$searchForOccurrences$0(
at com.intellij.util.indexing.FileBasedIndex.lambda$ignoreDumbMode$0(
at com.intellij.util.indexing.FileBasedIndexImpl.ignoreDumbMode(
at com.intellij.util.indexing.FileBasedIndex.ignoreDumbMode(
at com.intellij.find.impl.IdeaIndexBasedFindInProjectSearchEngine$MyFindInProjectSearcher.searchForOccurrences(
at com.intellij.find.impl.FindInProjectTask.getFilesForFastWordSearch(
at com.intellij.openapi.application.impl.NonBlockingReadActionImpl$Submission.insideReadAction(
at com.intellij.openapi.application.impl.NonBlockingReadActionImpl$Submission.lambda$attemptComputation$2(
at com.intellij.openapi.application.impl.NonBlockingReadActionImpl$Submission.attemptComputation(
at com.intellij.openapi.application.impl.NonBlockingReadActionImpl$Submission.executeSynchronously(
at com.intellij.openapi.application.impl.NonBlockingReadActionImpl.executeSynchronously(
at com.intellij.find.impl.FindInProjectTask.findUsages(
at com.intellij.find.impl.FindInProjectUtil.lambda$findUsages$0(
at com.intellij.find.impl.FindInProjectUtil.findUsages(
at com.intellij.find.impl.FindInProjectExecutor.findUsages(FindInProjectExecutor.kt:33)
at com.intellij.find.impl.FindPopupPanel$20.performInReadAction(
at com.intellij.openapi.progress.util.ReadTask.lambda$runBackgroundProcess$0(
at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(
at com.intellij.openapi.application.ReadAction.compute(
at com.intellij.openapi.progress.util.ReadTask.runBackgroundProcess(
at com.intellij.openapi.progress.util.ProgressIndicatorUtils.lambda$runUnderProgress$5(
at com.intellij.openapi.progress.ProgressManager.lambda$runProcess$0(
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(
at com.intellij.openapi.progress.ProgressManager.runProcess(
at com.intellij.openapi.progress.util.ProgressIndicatorUtils.runUnderProgress(
at com.intellij.openapi.progress.util.ProgressIndicatorUtils.access$100(
at com.intellij.openapi.progress.util.ProgressIndicatorUtils$
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$
at java.base/ Method)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$
at java.base/

Comment actions Permalink

I also experience this problem.

Check if your content root directory of your project is set. If not, just click "Add Content Root" then set the root directory of your project.

-> File > Project Structure > Modules

then save it.

Find in Path will now work properly because the root directory of the project is now set.


Comment actions Permalink

I had the same issue - pycharm professional edition 2019.3

File -> Invalidate Caches / Restart fixed it.

Comment actions Permalink

I have been having the same problem and living with it FOR MONTHS.

Rider 2021.1 EAP 7.

After reading this thread, I tried File -> Invalidate Caches / Restart and it worked. My files which never showed up in search no matter what i did, even when i had them open in the editor, now show up.

This is not the first time I have tried to fix this. Not the first time I have searched. This is a ridiculous problem to have and should be fixed by the vendor.

I am a licensed user for years, paying for this tool to mess with my head like this.

There should at the very very very very least be a button in the search results dialog saying "something missing that you know should be here? press here to Invalidate your Cache and Restart"
But really, just fix the damn thing.


Comment actions Permalink

Same issue with IntelliJ 2021.1. Solution: File-> invalidate cache->Restart

Comment actions Permalink

I had a scope defined - there was a file I wanted to ignore inspections for.

Deleting the scope so I had none remaining seems to have fixed the problem.

Edit: nevermind. Still spotty. Seems like it works 25% of the time.

Edit: If I select text and press ctrl+shift+f it doesn't work. Typing it in manually works better?

Edit: I can't quickly navigate to files either. Hm.

Comment actions Permalink

I experience this issue frequently and have to invalidate cache almost every two or three days. This is extremely annoying. Intellij used to be more reliable. I am considering the other options of IDE solely due to such bugs.

Comment actions Permalink

Could you please check 2021.1.1 Preview build, it contains the fix of a similar problem (

Comment actions Permalink

I saw this issue for the first time today after upgrading to PyCharm 2021.2 (CE). Was only seeing it in one of my projects. Invalidating cache did not help. But deleting the .idea folder and restarting, did help.


Please sign in to leave a comment.