How add an already existed conda environment to pycharm as an interpreter


I installed anaconda and make an environment by commands from anaconda website. Now, the problem is i do not know how add already existed environment to pycharm. Please help me to do that. Thanks for your help


Hi, you can add the existing conda environment by creating a new interpreter in PyCharm > selecting Conda environment > Existing environment > specify the path to python.exe inside your created environment.



I cannot see ANY EXISTING interpreters from my conda environments.  They simply are not showing on the dropdown menus. 

Conda environments and their interpreters are installed in "ProgramData", which is hidden by default in Windows 10.  I have them showing in Windows 10, but PyCharm does not pick up this configuration setting in Windows.

This has been like this for many PyCharm versions.  

Nor is the "Show Hidden Files and Folders" icon showing on the Main Toolbar.  This is frustrating !! 

This is a BUG and needs to be fixed. 


Rich Lysakowski Could you please submit a bug report to with some screenshots to demonstrate the issue, and Logs from **Help | Collect Logs and Diagnostic Data**?


How this is reproduced in some of my students .. was this solved or should i open a new ticket ?


Yes, please report it to our issue tracker providing screenshot(s) showing the issue and idea.log file from Help | Show Log in...


Yep, same issue. Neither of those solutions work for us.


Hello Jonathanwilliammugan 

If none of the suggested fixes works, please create an issue on YouTrack or contact us directly with Help | Contact Support.


Seems it is fixed, or not a bug (windows 11 tested)
first, I added \AppData\Local\miniconda3\Scripts\conda.exe
next, clicked “load environments”
last, selected an existing env


Please sign in to leave a comment.