RubyMine searches the debug gems in the remote path

Answered

Linux 2109.3.1 beta (and a few previous versions) don't find the debugger gems at /opt/RubyMine/plugins/ruby/rb/gems/ when used with a remote SDK: it searches on the remote path instead on the local path. 

I have all my rails apps in docker containers run with docker-compose. I connect to them using ssh remote SDK (because the docker-compose SDK is still a pain for a few reasons). It was working with the 2019.2(something), but with the 2109.3+ I have to mount a volume in the container /opt/RubyMine:/opt/RubyMine and it finds and uses it.

That means that it searches in the remote path, not in the local one. That is quite a pain considering the number of apps that I have to use, and considering that I have to add an docker-compose.overwrite in all of them.

How can I configure that without having to mount the local volume on the remote path? 

Any work around?

 

4 comments
Comment actions Permalink

Hello Domizio,

just to be sure, could you please check how it goes in RubyMine 2019.3.2 RC? In addition, what kind of Docker issue have you faced?

0
Comment actions Permalink

Sorry for the delay. I couldn't update RM before.

Now that I did, with 2019.3.2, the situation is even worse, since the workaround of mounting the local /opt/RubyMine into the remote does not work anymore!

10:42 PM Error running 'server (ruby)'
Failed to Install Gems. Following gems were not installed:
/opt/RubyMine/plugins/ruby/rb/gems/ruby-debug-ide-0.8.0.beta21.gem: Could not find a valid gem 'ruby-debug-ide-0.8.0.beta21.gem' (>= 0) in any repository
/opt/RubyMine/plugins/ruby/rb/gems/debase-0.3.0.beta23.gem: Could not find a valid gem 'debase-0.3.0.beta23.gem' (>= 0) in any repository

An they are both there with access:

$ [ -r /opt/RubyMine/plugins/ruby/rb/gems/ruby-debug-ide-0.8.0.beta21.gem ] && echo $?
0

$ [ -r /opt/RubyMine/plugins/ruby/rb/gems/debase-0.3.0.beta23.gem ] && echo $?
0

The Docker issue that I reported 2 years ago has just been declared fixed in the next version: https://youtrack.jetbrains.com/oauth?state=%2Fissue%2FRUBY-20539

 

What is the recommended work around for this one?

0
Comment actions Permalink

Hello Domizio,

could you please specify why you're adding debug gems that way and not just using their names? As for the issue you've mentioned, there're possible options mentioned in https://youtrack.jetbrains.com/issue/RUBY-20539#focus=streamItem-27-3940552.0-0 and available in 2020.1 EAP.

0
Comment actions Permalink

What? I am not adding any debug gem in any way. When I try to use the debugger RM asks if I want to install them. If I just confirm, then it doesn't find them regardless the fact that it searches them in the right path, which is the real path of my RM installation (and as I show you in the previous message they are indeed files in the right path)!

0

Please sign in to leave a comment.