How to change shell for ruby test

Answered

When I run a test named `・` from Rubymine following command is executed.


/bin/zsh -c "bash -c 'env RBENV_VERSION=2.5.5 /Users/ironsand/.rbenv/libexec/rbenv exec bundle exec ruby -Itest /Users/ironsand/dev/my_project/test/models/post.rb --name '\"'\"'/test_\・/'\"'\"''"

That causes "invalid multibyte character" error. 

When I run the command without `/bin/zsh -c`, the test runs fine.

How can I configure if I want to omit `/bin/zsh -c` from all test commands?

 

In `Preferences`->`Tools`->`Terminl`->`Application settings`->`Shell path`, I set `/bin/bash`.

I couldn't find any place that I can change shell config.

 

Thanks.

3 comments
Comment actions Permalink

Hello,

what is the system shell? What is the output of 

echo $SHELL

 

0
Comment actions Permalink

Hello,

 

System shell is "zsh" and "echo $SHELL" returns "/bin/zsh".

I only want to use `bash` for the "minitest".

 

Thanks.

0
Comment actions Permalink

Hello,

sorry for the delay in response. At the moment we're using user shell but it'll be the same for all the Run configurations.

0

Please sign in to leave a comment.