No "Emulate terminal in output console" option in PyCharm for Windows

Answered

I'm running PyCharm 2019.3 on Windows 10.

In order to have PyCharm behave well with progress bars (tqdm, in my case), I found online (e.g., https://stackoverflow.com/questions/45012964/stdout-progress-bars-dont-work-in-pycharm) that some users recommended checking "Emulate terminal in output console" in the "Edit Configurations" menu, but I don't have such a setting. Another suggested option, "Show command line afterwards" is also absent.

Is their an equivalent recommendation under Windows for proper progress bar behavior?

 

 

2
8 comments

Do you use a remote interpreter?
This option is only available when using a local interpreter.

https://youtrack.jetbrains.com/issue/PY-29204

0

I am indeed using an ssh interpreter. I guess I'm out of luck then.

1

Hi Sergey Karpov. I can't seem to find this option either. I am working on a django application and I am not using a remote interpreter. Is the interpreter remote by default when working on django projects?

0

Abbas Egbeyemi could you share a screenshot showing your run configuration?

0

Django Server run configuration doesn't have this option, unfortunately. So it's by design.

0

I also could not find “Emulate terminal in output console”  option when I try to run a pytest function on MAC. The following is the scrennshort of my configuration page.

0

Please sign in to leave a comment.