How to check the folder of my project? [Solved]


(I figured it out, I need to attach a folder to it somehow.)


Hi experts,

I have no idea how to check where is my project, because I think Datagrip did not create it under the default project directory (I manually created a few folders and they don't show up). Is there a way to check where the project is? Thanks


Yes, this moment is kind of unclear. I have created a bunch of connections and cannot see where the “project” is stored.

Actually DataGrip "shows" that it's in my home directory (I have even renamed it in the IDE to pop out more) - but no, cannot see any directory with the name of my project.


Hi Levan Kekelidze 

You can view the location of your current project in the Files window (View → Tool Windows → Files):

Unless something else is specified in the default project directory setting, this is the default location for all new projects.

To navigate to the project directory on disk, you can right-click the content root folder in the Files window and select ‘Open in’ → Explorer (or Finder).


Hi, Arina Efremova.

Em, nope, I see nothing there.

in the default project directory settings

I have an empty field there (i.e. no specific directory defined).

Maybe it's because I only created connections and use them, maybe the notion of a “project” involves other step.I am just in the process of learning DataGrip, and I am liking it the more I learn it. Have to get used to some new concepts etc.

I just see that DataGrip "says" that my project is located in my home directory on macOS, but in reality - there is no such folder there (neither normal, nor hidden):


Maybe it's because I only created connections and use them, maybe the notion of a “project” involves other step

Nope, each workspace is a separate project. You can attach other folders to it to view them in the Files window, but under the hood each parent project has its own unique configuration settings residing in a unique folder (.idea).

Are there any symlinks set up for the home directory?

Can you see the project folder in DataGrip's built-in file browser if you click Open… in the project drop-down?

Things to try:

  • Create a brand new project via File → New → Project in the default location (just type in the project name when prompted)
  • Repeat the step above, only now select a different folder outside of the home directory

Hi, Arina Efremova 

Are there any symlinks set up for the home directory?


Can you see the project folder in DataGrip's built-in file browser if you click Open… in the project drop-down?



Things to try: …

I have tried both of your suggested option and it worked: in the newly created projects I can see the project folders, unlike my initial work folder.

Here are the results for both of your suggested options:

  • The first new project was created in the “~/DataGripProjects/foo_db” (I didn't specify any folder, just typed the project name).
  • For the second project I specified a custom location (Downloads folder): ~/Downloads/test_db

Both new project folders can be easily located on my hard drive. And for both of them I see the project path in the “Files” view now (again, this is unlike my initial work project, see the screenshot in the previous reply):

I don't have any specific default location configured for new projects in the DataGrip settings, and seems like for this case the latest version of DataGrip (version 2023.3.4 as of now) chooses “~/DataGripProjects” as the default project location (on macOS).

Strange moments

I have spotted two strange moments about my “invisible” project which are seen in the “Project” widget / dropdown menu:

  1. The project folder is missing at the end of the location path. I.e. instead of “/Users/levan/onoff_db” it is shown as “/Users/levan”
  2. The locations of the two new projects are shown as “~/path” and for my “invisible” project - as a full path (“/User/levan”), i.e. not with the tilde sign “~”. A bit strange / inconsistent.

Here is the screenshot to illustrate these two strange moments:


Thanks Levan. Good to know new projects are created and accessible as expected.
As for your initial project, I would be able to tell you more if I could take a look at the application logs: Help | Show Log in Finder. The file can be uploaded privately to

Hi, Arina Efremova 

I have uploaded the idea.log file using the JetBrains Upload Service, as you requested:

Upload id: 2024_02_29_9mGmxDuXeCuYCp4ok2sNxp (file: idea.log)


I also took a look in that file and I guess I now know where is my “invisible” project's data are located:
👉 /Users/levan/.idea

I saw references to this hidden directory in the idea.log file. I compared the directory content with the newly created test project and saw that the project file should be called <project_name>.iml. But for my "invisible" project there is only one “.iml” file in the above mentioned directory and it's called levan.iml (despite the fact that I recently renamed the project to "onoff-databases", so the correct name should have been “onoff-databases.iml”).

And here is a screenshot comparing the contents of .iml files for my “invisible” project and for the new test project, where you can see that in the “invisible” project's .iml file there is one XML element is missing - "<content>":

Hope this helps.


Hi, Arina Efremova.

I now have the clear understanding of this issue with my “invisible” project. For some reason, in the past my initial project was created right in my home directory and had the same name as my user directory (which is “levan”). By researching DataGrip's logs and the project file and folder structure on my disk I understood that DataGrip was actually kind of correctly showed my project name: the “/Users/levan” was both the path where my project resided and the project name, i.e. it considered my whole home directory as the folder where my project was located etc.

I have managed to fix this issue with invisible project with the following steps:

  • closed my project in DataGrip and removed it from the list of recent projects
  • manually created a new folder “onoff-databases” in the “~/DataGripProjects” directory (it could be of course another directory)
  • moved the “.idea” invisible directory to the new “onoff-databases” directory created on the previous step 
  • manually renamed the existing project file “levan.iml” to the “onoff-databases.iml”
  • manually updated the contents of the .iml and “modules.xml” configuration files (just compared the content with the newly created test project etc)

After performing the above steps I opened my “refreshed” project (selecting the “onoff-databases” directory in the new location) and everything if fine now: I can finally see the project directory in the “Files” tool window, everything works as it should etc 🎉

I now have a clear understanding how DataGrip projects are organized, the general principles etc. While researching this issue that I reported, I gained useful experience and learned DataGrip more 💡.

Thank you, Arina, for the useful tips.
I have no further questions, the problem is now solved ✅.


Please sign in to leave a comment.