Editor tabs issue

Hello,

I am experiencing so much trouble with editor tabs in PHPStorm, under Windows 10.

The tabs overlaps others, they let a gap with other tabs, they don't want to move anymore and when a tab is stucked, I can't close it, neither by contextual menu, nor the close button.

It happens more often when I am moving tab to another windows of the same project.

My PHPStorm is up to date and I am experiencing this bug for a long time, it still not solved.

Due to my configuration, to move a tab, I have to press Alt to drag and drop files, because otherwise the files were often moved by mistake.

PS: I don't think this is specific to PHPStorm but I only own this product.

4 comments
Comment actions Permalink

Could you please record a screencast capturing the whole IDE window (all of them if there are multiple) that would show how we can reproduce the issues on our side?

Before that, please turn off all custom plugins (Settings/Preferences | Plugins | Installed | Downloaded) and restart the IDE.

Also, please let us know the exact product version.

0
Comment actions Permalink

Hello,

Thank you for your answer.

I am not sure to be able to reproduce all bugs but on this video I succeeded to reproduce 2 of them.

https://youtu.be/McYq1_lJEFs

Second bug is closed to 1:15.

Disabled plugins

Version

PhpStorm 2019.3.2
Build #PS-193.6015.48, built on January 22, 2020
Licensed to (me)
Subscription is active until August 27, 2020
Runtime version: 11.0.5+10-b520.30 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1963M
Cores: 8
Registry: run.processes.with.pty=TRUE
Non-Bundled Plugins:
0
Comment actions Permalink

Thank you for the screencast! I am struggling to reproduce the issue, and also cannot find similar reports on the tracker. Since it is happening even with custom plugins off, it makes me think about two possible causes:

1. The installation is broken. Please uninstall PhpStorm and install it back leaving the settings intact

2. If 1 didn't help, probably there's something in your config that causes it. Please rename the %USERPROFILE%\.PhpStorm2019.3 folder, start PhpStorm, don't import settings when asked and check how it goes now

0
Comment actions Permalink

Hello,

I only tried the second case and it seems related to my configuratio. A brand new workspace seems okay but when I import settings from my account & restart, its becomes crazy again. I think this is caused by the config I set Alt + Drag to move a file.

I will try more from my configuration, by disabling this one, first.

EDIT: This was this setting, with all my config, I only disable drag-n-drop files with ALT pressed and it now works fine.

EDIT: The IDE allows me to press ALT to drag-n-drop even if this option is disabled and bugs seem to occur then too. So this is related to the ALT key and not the configuration itself.

0

Please sign in to leave a comment.