WSL RubyMine "Could not get RubyGems environment for remote"

Answered

I am using a fresh install of WSL and I seem to be unable to setup the remote for Ruby in RubyMine. I put the error message in the title and here is a screen cap. Any help would be greatly appreciated. 

5 comments
Comment actions Permalink

Update on this. This appears to be an issue specific to Pengwin. I was able to get it working using Ubuntu. Hope that helps!

0
Comment actions Permalink

Ok I figured it out. For some reason using WSL you have to use the ".rbenv/versions/<version>/ruby/bin" path rather than the Shim. 

 

This probably is something that RM should eventually address.

0
Comment actions Permalink

Hello Michael,

in case you add a remote rbenv SDK you need to use the path to rbenv executable rather than to a certain Ruby SDK.

1
Comment actions Permalink

Thanks for that Olga! Ok so I have made the change here and it gets me over that hurdle, but then I hit another -- RM can't see any gems for that Ruby. On WSL the gems are there and it runs fine via `rails s`.

0
Comment actions Permalink

Michael,

it appears to be a known problem related to Pengwin, please add your vote and follow https://youtrack.jetbrains.com/issue/RUBY-25253

0

Please sign in to leave a comment.