virtualenv dont activate using terminal of pycharm

virtualenv don't activate using terminal of pycharm, in my ubuntu pycharm version it's ok, but in my windows version can't use. I need activate using the following commands myvenv\Scripts\activate.

Which are the configuration of my IDE pyCharm for to activate mi venv using my terminal?

Thanks

4 comments
Comment actions Permalink

Please check [File | Settings | Tools | Terminal | Activate virtualenv] option, make sure it's enabled. If that doesn't help, make sure your project interpreter is actually a virtualenv.

0
Comment actions Permalink

Thanks Andrey, but my IDE was configured that way, but I don't still activate my virtualenv using my PyCharm terminal,with this command 

myvenv\Scripts\activate. The only way was using that command it's I create the venv using the IDE not the PyCharm terminal.

 

0
Comment actions Permalink

Andrew, if I create my venv using the following commands virtualenv venv, this venv configuration like this (see the picture) and has a error when I use venv\Scripts\activate.

 


Thanks for your answer

 

 

 

0

Please sign in to leave a comment.