bad option: '-target:jvm-11'

Hi.

I'm currently using Intellij IDEA Ultimate EAP (Build #IU-201.5616.10, Runtime version: 11.0.6+8-b722.15 x86_64) to write mixed scala + java code and building it with Gradle (see configuration on screenshot).

Version of gradle in gradle-wrapper.properties is 5.6.4, Java version is 11.0.6, Scala version is 2.12.10
I'm constantly getting:

Error:scalac: 'jvm-11' is not a valid choice for '-target'
Error:scalac: bad option: '-target:jvm-11'

 

How can I fix it?

1 comment
Comment actions Permalink

The same crap when trying to run unit test in the module totally written in Kotlin (!)

0

Please sign in to leave a comment.