AppCode hung on "Starting" or "Prepare build" — (or: "Why I finally gave up on AppCode")

Both AppCode 2019.3.5 and 2020.1 EAP exhibit the same behaviour. On a small codebase (less than 400 lines total code—my "experiments project"—hitting ⌘+B frequently says "Prepare build" and does nothing else. Just sits there. I eventually switch to Xcode to build and end up coding there for a while. Sometimes when I switch back to AppCode it's actually started and completed the build. Most times, though, when I switch back to AppCode it's still stuck on "Prepare build". If I click the "Stop" button and cancel the build, and then hit ⌘+B again, AppCode will (most, but not all times) wake from its deep thought and actually do my bidding—taking about 10-15 seconds to do so... by which time my train of thought has been interrupted and I find myself asking why I continue to bother with AppCode.

This is occurring on an 2019 iMac 27" with 72GB RAM, 8 cores, and almost nothing else running on the machine.

Anyway, at this point I am officially done with AppCode and will be letting my subscription lapse.

I've tried long and hard to make AppCode "work", but at 9pm at night when I'm wanting to "just get through" some code, I don't need my tools hanging on my or exhibiting other spurious / weird behaviour.

1 comment
Comment actions Permalink
Official comment

Hi Stuartro,

We are very sorry to hear that. In case you reconsider, I've created ticket OC-19692 for your case in our tracker. Please add #com.jetbrains.cidr.xcode to "Help > Diagnostic Tools > Debug Log Settings", reproduce hang, and attach AppCode logs "Help > Show Logs in Finder" to the ticket. Also it will be very helpful to have CPU snapshot attached.

Please sign in to leave a comment.