Creating a new file won't focus the filename input

Hey,

When i try to create a new file (for example a javascript one) it won't autofocus the filename, it's keeping focusing the file i opened in the editor.

 

I'm on Arch Linux with KDE Plasma 5.18 and Phpstorm  2019.3.3

10 comments
Comment actions Permalink

Please try to disable the "File | Settings | Appearance & Behavior | Appearance > Automatically position mouse cursor on default button" checkbox.

Does it help?

0
Comment actions Permalink

Oh, that worked! thanks :-)

0
Comment actions Permalink

Enabling this checkbox has helped me. I'm using Kubuntu 18.04.4 LTS.

It was very annoying!

0
Comment actions Permalink

But now autofocusing of a mouse cursor is annoying too! Life is pain! :(

0
Comment actions Permalink

I have this issue also every time.

If I work in VSCode it happens also. But there with a click onto window focus gets set correctly. Not in Jetbrains products. Not in Webstorm, not in Phpstorm.

Is it Java? Is it jetbrains products? Or maybe it'c combination of both that makes using that software so hard.

 

Why is it impossible to make software, which just works like expected and not like developers think it should work.

Crazy stuff.

 

Time to switch to VSCode and cut the line.

0
Comment actions Permalink

I can't reproduce that on Linux in 2020.1.2: https://recordit.co/x6cD7cIx7j
I even tried to invoke the right-click menu while the IDE was out of focus, it still worked.
Any particular steps for reproduction? Including the OS for those who are not on Linux.

0
Comment actions Permalink

I have the same issue: https://drive.google.com/file/d/1wZHKNhHxS51JeZ8JTVpilBHwLmCRfdZw/view?usp=sharing

The issue persists if I restore the default settings.

The setting described here does not even exist for me.

My specs: 

~ >>> cat /etc/lsb-release                                                                                                                                                                                        
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=20.0.3
DISTRIB_CODENAME=Lysia
DISTRIB_DESCRIPTION="Manjaro Linux"
~ >>> pacman -Q phpstorm
phpstorm 2020.2b202.6397.115-1
0
Comment actions Permalink

Roman

Unfortunately still not reproducible on my end. 

Do you have PhpStorm installed via pacman? Please try to delete it & install from an archive available on our site: https://www.jetbrains.com/phpstorm/download/#section=linux

If that doesn't help - please report this to our bugtracker at https://youtrack.jetbrains.com/newIssue. It would be great if you could also attach there the information gathered using the https://intellij-support.jetbrains.com/hc/en-us/articles/360011841360-Reporting-focus-problems article.

0
Comment actions Permalink

I have had this issue when I run Intellij using the latest available JVM (I have tried with Oracle Jdk-14.0.1 and then with Java.Net 14.0.2-open). So I switched to Intellij JVM Runtime v11 using the Jetbrains Choose Runtime plugin and then the problem stopped.

 

0
Comment actions Permalink

I can confirm Alexandre Alessi 's solution.

Installing phpstorm-jre from AUR fixed it for me on Manjaro.

0

Please sign in to leave a comment.