Creating a new file won't focus the filename input


When i try to create a new file (for example a javascript one) it won't autofocus the filename, it's keeping focusing the file i opened in the editor.


I'm on Arch Linux with KDE Plasma 5.18 and Phpstorm  2019.3.3


Please try to disable the "File | Settings | Appearance & Behavior | Appearance > Automatically position mouse cursor on default button" checkbox.

Does it help?


Oh, that worked! thanks :-)


Enabling this checkbox has helped me. I'm using Kubuntu 18.04.4 LTS.

It was very annoying!


But now autofocusing of a mouse cursor is annoying too! Life is pain! :(


I have this issue also every time.

If I work in VSCode it happens also. But there with a click onto window focus gets set correctly. Not in Jetbrains products. Not in Webstorm, not in Phpstorm.

Is it Java? Is it jetbrains products? Or maybe it'c combination of both that makes using that software so hard.


Why is it impossible to make software, which just works like expected and not like developers think it should work.

Crazy stuff.


Time to switch to VSCode and cut the line.


I can't reproduce that on Linux in 2020.1.2:
I even tried to invoke the right-click menu while the IDE was out of focus, it still worked.
Any particular steps for reproduction? Including the OS for those who are not on Linux.


I have the same issue:

The issue persists if I restore the default settings.

The setting described here does not even exist for me.

My specs: 

~ >>> cat /etc/lsb-release                                                                                                                                                                                        
~ >>> pacman -Q phpstorm
phpstorm 2020.2b202.6397.115-1


Unfortunately still not reproducible on my end. 

Do you have PhpStorm installed via pacman? Please try to delete it & install from an archive available on our site:

If that doesn't help - please report this to our bugtracker at It would be great if you could also attach there the information gathered using the article.


I have had this issue when I run Intellij using the latest available JVM (I have tried with Oracle Jdk-14.0.1 and then with Java.Net 14.0.2-open). So I switched to Intellij JVM Runtime v11 using the Jetbrains Choose Runtime plugin and then the problem stopped.



I can confirm Alexandre Alessi 's solution.

Installing phpstorm-jre from AUR fixed it for me on Manjaro.


I have the same issue with Intellij IDEA, installed via the standard package manager. I am running Manjaro linux with KDE. IDEA runs on its own JDK 11.0.12. There is also no "Automatically position mouse cursor on default button" config for me as was suggested by Vasiliy.

UPDATE: Fixed by configuring Jetbrains JDK. I didn't realize I was running on a stock one from Oracle. For some reason Intellij wouldn't pick up configuration from idea.jdk file. Fixed by setting IDEA_JDK explicitly:

IDEA_JDK=$HOME/.jbr/jbr_jcef-11_0_12-linux-x64-b1504.27 /usr/bin/idea


Thanks so much, olegua. This fixed it for me as well! I'm on Arch as well and Intellij as well as all other JetBrains IDEs have the same problem for me. Fixed now though!


Thanks, this helped for me.


Please sign in to leave a comment.