Control parameter encoding in editor based http client

I'm using the editor based http client to query an OData api but I'm having issues. In OData there is a syntax to provide a filter and it looks like this:

GET http://example.com/service/Data?$filter=key eq value

The spaces in the filter expression are important and the only allowed encoding is percent encoding but no matter how I write my query the spaces are always replaced with + upon execution making the query invalid. Is there any way to disable this behaviour?

# Even if I do this
GET http://example.com/service/Data?$filter=key%20eq%20value
# It will be executed as this
GET http://example.com/service/Data?$filter=key+eq+value
1 comment
Comment actions Permalink

Looks like this is known issue https://youtrack.jetbrains.com/issue/WI-40402. We've also created a separate report: https://youtrack.jetbrains.com/issue/IDEA-234779 - feel free to vote for or comment it in order to get notified about its updates.

0

Please sign in to leave a comment.