Always in multi-insertion mode?

The editor is behaving strangely where if I paste text inside a comment /** */ enclosure, something strange happens. the new lines appear in front of the lines below the comment section and at the end of each line is an insertion bar. It's the most annoying thing. There are rare occasions where this is nice but 99% of the time I don't need that. 

5 comments
Comment actions Permalink

I'm not using Vim with no Vim plugins. There is no 'tell' in the log. 

0
Comment actions Permalink

Does the same happen if you paste using mouse via right click > "paste" or "paste without formatting"?

0
Comment actions Permalink

Hi Dmitry, 

Yes, same thing happens with mouse Paste and Paste without Formatting. 

If this helps, on a normal editor, if you click in the middle of the line the cursor appears at the left edge. But in this current setup if I insert in the middle of a line, the cursor remains at that spot. Pasting then puts the code down the middle of whatever is below the insertion. Once the paste ends, all the line endings have a blinking cursor. That's the multi-insertion piece. 

0
Comment actions Permalink

I cannot say what is different. This morning dropping a cursor in the middle of a line now works as expected. 

0
Comment actions Permalink

If it happens, again, please try these two suggestions:

  • File | Invalidate Caches / Restart | Invalidate and Restart
  • If it didn't help, disable all custom plugins and restart the IDE

We have no similar reports so far, so it was either indexing broken in an exotic way or a plugin.

0

Please sign in to leave a comment.