Error configuring SDK when adding existing / new conda environment as python interpreter

Hi all,

I just reinstalled pycharm and miniconda3, created a conda environment with the following commands

#create an environment and add biopython
conda create --name conda_env1 biopython
#activate the environment
conda activate conda_env1

and tested the environment using the anaconda prompt.

When I try to use the environment as python interpreter for a pycharm project, I go to Add Python Interpreter - Conda environment - Existing environment, the environment created is listed, but when I select it I get the following error

Error configuring SDK: 1 : child= 'Miniconda3 -> 2'; child.nameEqualTo(nameId)=false; child.getClass()=class com.intellij.openapi.vfs.impl.FilePointerPartNode; child.nameId=188; child.getName()='Miniconda3'; nameId=31499; name='miniconda3'; compare(child) = 0; UrlPart.nameEquals: true; name.equals(child.getName())=false.
Please make sure that C:\Users\xxxxx\miniconda3\envs\conda_env1\python.exe is a valid home path for this SDK type.

I also tried to create a new conda environemnt from pycharm, and it gave me the same error.

Many thanks for any help with this, I would really like to be able to use conda envs!





Do you by any chance use network-mounted folders, or symlinks anywhere in the interpreter configuration process? 

Could you share your [IDE logs]( ?

You can upload them to our FTP: [FTP]( and let me know the file name.


Hi Andrey,

Thanks for your reply, no the interpreter configuration is just based on standard conda environment creation and selection. I have uploaded my log files with name

Many thanks for your help!

I have the same issue, using the latest Miniconda. The error happens when creating a new environment using IntelliJ, importing an existing conda environment, or importing the existing conda environment.

The problem does not occur in PyCharm 2019.2.1 (Community Edition) build PC-192.6262.63

Is there a fix?


Thank you, but unfortunately I could not find the file with that name on our FTP server. 

Could you please try a clean reinstall of PyCharm while also deleting all of the related directories for 2019.3 and 2020.1 versions:

[Default directories for PyCharm 2020.1](

[Default directories for PyCharm 2019.3](

If that doesn't help, please submit an issue to, and attach IDE logs, and also your miniconda version.


I was getting a similar error. There was some problem in the path due to some previous set of commands I had run. I could not fix that (tried deleting and recreating the source env, and even the source code directory but it didn't work). Choosing a different env name worked for me. For example, instead of `conda_env1`, choose something else.


getting same thing 


Hello Iain Collins and V S Shkodin

I am wondering if you use the same name `conda_env1`? Could you please attach a couple of screenshots: activated conda env in the terminal, the configuration of existing interpreter in PyCharm and the error on the creation step? 

Please also upload your logs folder zipped from ***Help | Collect logs and Diagnostic Data***    to the FTP and please let me know the filename. 


 I gave up on this error for a while & just used my linux machine. Today I had another look at my Windows machine. Turned out to be a simple error in my User variables PATH. It was pointing to an old python version that was no longer installed on my machine. Not 100% sure how this happened. In hindsight it's something I should have checked first.

ATB iain


Please sign in to leave a comment.