No valid license found

Completed

Hello, I try to launch clion on a linux machine with clion-2019.3.4/bin/clion.sh, but I get following error

Do you have any idea about it? Thanks

Cheers

Zhi

 

ERROR -         #GeneralLicenseManager - No valid license found

java.lang.Throwable: No valid license found

at com.intellij.openapi.diagnostic.Logger.error(Logger.java:145)

at com.intellij.ide.a.l.aX.d(aX.java:216)

at com.intellij.ide.a.l.aX.b(aX.java:117)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:498)

at com.intellij.idea.MainImpl.start(MainImpl.java:94)

at com.intellij.idea.StartupUtil.lambda$startApp$5(StartupUtil.java:246)

at com.intellij.util.ui.EdtInvocationManager.executeWithCustomManager(EdtInvocationManager.java:73)

at com.intellij.idea.StartupUtil.startApp(StartupUtil.java:241)

at com.intellij.idea.StartupUtil.prepareApp(StartupUtil.java:213)

at com.intellij.ide.plugins.MainRunner.lambda$start$0(MainRunner.java:45)

at java.lang.Thread.run(Thread.java:748)

ERROR -         #GeneralLicenseManager - CLion 2019.3.4  Build #CL-193.6494.38

ERROR -         #GeneralLicenseManager - JDK: 1.8.0_222; VM: OpenJDK 64-Bit Server VM; Vendor: Oracle Corporation

ERROR -         #GeneralLicenseManager - OS: Linux

 

6 comments
Comment actions Permalink

Hello!

Please specify your OS and the content of the clion.jdk file from ~/.CLion2019.3/config.

0
Comment actions Permalink

Hello,

Thanks for your reply.

Here is the information:

cat /etc/redhat-release
CentOS release 6.9 (Final)

and in ~/.CLion2019.3/config, there is only one 'port.lock' file, no 'clion.jdk' file.

Regards,

Zhi

 

0
Comment actions Permalink

It seems CLion can't open the License dialog to let you set the licensing options. Do you work on your Linux workstation directly, or access it remotely? Do you have the DISPLAY variable set?

0
Comment actions Permalink

Hello,

Thanks for your reply.

I'm access the remote CentOS server via ssh.

After your suggestion, I have installed an X server on my local Mac OS, and enabled X11 forwarding.

Now on my remote server, I have DISPLAY variable set.

$ echo $DISPLAY
localhost:10.0

$ echo $TERM
xterm

But I still get the same error, and still empty ~/.CLion2019.3/config foler.

 

0
Comment actions Permalink

So when you do 'export DISPLAY=...' in terminal and then start CLion in the same terminal - it doesn't work? In this case please create an issue here: https://youtrack.jetbrains.com/issues/IDEA. My colleagues will help you.

0
Comment actions Permalink

Thanks Anna, I will create the issue ticket.

0

Please sign in to leave a comment.