How to set a default build directory OUTSIDE the source directory.


Please please please how do you set the default build dir to be outside the source directory?  It's incredibly frustrating that clion insists on polluting the source.  Every single time, I have to remember to change this manually (in the preferences which seem like they're for the whole of clion but are actually project-specific) and then it leaves a build in the source anyway, which I then have to clear out and make git incredibly slow as it deals with the hundreds of files sprinkled in there.


1 comment
Comment actions Permalink


File | Settings | Build, Execution, Deployment | CMake are indeed project-specific:

However you can configure one or several default CMake Profiles which will be used for all your new CLion projects in File | Other Settings | Settings for New Projects….


Please sign in to leave a comment.