Remote Interpreter File Not Found error when trying to use debugger

I thought PyCharm was supposed to make things easier, I don't know what's worse, debugging my program or using yours.

I have a remote interpreter setup with ssh and my development folder is a Samba share from the same server mapped as Z:\_DEV\_Python_Scripts. I developing from a Window 7 system. When I try to use the debugger, I keep getting FileNotFoundError. I tried following the steps in the link below, but it still won't work. I see "Connecting.. Connected". Then I get "No Such File or Directory" exception for the Python source file I'm trying to debug.

The only thing I can see wrong is the slashes in the pathname are forward slashes and since its a mapped drive they should be backslashes. However, when I check the settings, the slashes are correct.

I'm at a loss at what to try next. I created a log according to the link below, but I'm not sure how to submit it.

https://intellij-support.jetbrains.com/hc/en-us/community/posts/360003445859-External-interpreter-not-working-Error-Can-t-run-remote-python-interpreter-Can-t-get-remote-credentials-for-deployment-server-

11 comments
Comment actions Permalink

Hi, 

>my development folder is a Samba share from the same server

From the get go, this is unsupported scenario. Please avoid working on projects in network-mounted folders. When working with SSH interpreter, you need to have local copy of the project as well.

0
Comment actions Permalink

Hi Andrey,

Thanks for your reply. Your answer is somewhat contrary to what is displayed in Settings->Deployment. The "Type" drop down menu offers the choice "Local or mounted folder" with an icon showing a networked folder. What am I missing? What is the point of having a local copy? I have to waste more space for what seems to only give me the ability to edit the file locally. It's all very counter intuitive. I'm using 2019.3.4 Professional

Thanks!

0
Comment actions Permalink

Ok, just for grins I created a local copy and setup a new project with the remote interpreter and I'm getting the same error.

0
Comment actions Permalink

>Your answer is somewhat contrary to what is displayed in Settings->Deployment. The "Type" drop down menu offers the choice "Local or mounted folder" with an icon showing a networked folder. What am I missing? What is the point of having a local copy?

This setting is for deployment only, e.g. you can automatically upload your project files to a mounted folder instead of SFTP, but requirement to have a local copy still stands. The point is that PyCharm performs quite heavy I/O operations while it indexes the project to provide completion, and there are known issues when doing that over network. 

If the issue is still reproduced with the local project, I'd like to look a bit deeper into your setup. First of all please try to delete/recreate your project interpreter, and if that doesn't help, could you please provide the following:

1. Screenshots of the project interpreter settings

2. Are you using any symlinks in your project?

3. Full output of the debug console after reproducing the issue. 

4. IDE logs: https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files

You can upload the logs to https://uploads.services.jetbrains.com/ and let me know the file name 

That should be enough for starters.

0
Comment actions Permalink

1. Screenshots of settings and debug output are included in the log zip file.

2. No symlinks

File name is: pycharm-logs-20200327-203450.zip

 

Thanks again Andrey!

0
Comment actions Permalink

According to the log, PyCharm can't access it's own .idea folder (in the project root)

2020-03-27 20:30:11,717 [ 102483]   WARN - tartup.impl.StartupManagerImpl - K:/_DEV/_Python/_Xen/.idea 
java.io.FileNotFoundException: K:/_DEV/_Python/_Xen/.idea
at com.intellij.openapi.util.io.FileUtil.isFileSystemCaseSensitive(FileUtil.java:1470)
at com.intellij.ide.startup.impl.StartupManagerImpl.checkFsSanity(StartupManagerImpl.java:322)
at com.intellij.ide.startup.impl.StartupManagerImpl.runPostStartupActivities(StartupManagerImpl.java:256)

Are you sure K:/_DEV/_Python/_Xen/ is a local folder? Not mounted or anything?

Please try creating a temporary project on your C: drive just to see if it works.

0
Comment actions Permalink

YES, I'm sure it is a local folder, NO, i'm not creating another folder on C:. My local disks are partitioned, and K is a partition on the same disk as C: This is really disappointing, I thought this was a mature product.

0
Comment actions Permalink

The .idea folder is right there. My account has admin rights.

0
Comment actions Permalink

This may indicate a file permission issue.

Let's try a simple test. Delete .idea folder from the project root. Then re-open that project in PyCharm, it should create new .idea folder. If there's any permission issues, at this point it should give an error.

0
Comment actions Permalink

If it were a permission issue then it should have also occurred when the project was created also, however I just deleted .idea, reopened the project, the .idea folder was recreated, I tried to use the debugger and got the same error. I should make it clear that my admin rights are permanent, I do not need to type a password for them. Here is a screenshot of the permissions in the project folder:

0
Comment actions Permalink

I also get this error in the Python console:

0

Please sign in to leave a comment.