Can't install PyAL package

I have been trying to install the PyAL package and cannot figure it out. I first went the way of using the installer for available packages and was met with this error that I have not been able to figure out:

Next, I tried to use the setup.py file but couldn't figure out why the option was greyed out:

Any help or insight into either would be much appreciated! Thank you!

 

EDIT: I forgot to mention for the installer for available packages I am using the most up to date pip and I'm using python 3.6 with the most up to date Pycharm Community.

1 comment
Comment actions Permalink

To install using setup.py, you need to run in the terminal:

$ python setup.py install

Make sure right python environment is activated.

Alternatively run:

$ pip install .

https://stackoverflow.com/a/1472014/10895914

0

Please sign in to leave a comment.