IntelliJ 2020.1 Double Click on Files in Local Changes

Answered

In IntelliJ 2019, when I double clicked on a file in the Local Change tab, it would open the file. Now, in 2020.1, it opens a diff of file. How do I change it back to the 2019 (and previous) behavior. I have tried changing the Keymaps to no avail.

6 comments
Comment actions Permalink

This behavior is specific to the non-modal commit UI. There is no way to change the behavior in the new commit - please vote for https://youtrack.jetbrains.com/issue/IDEA-235910

So as an option, you can switch back to the old UI to restore behavior.

Another option is to Jump to Source (F4) to open the file in editor instead of diff.

0
Comment actions Permalink

Perfect. Thanks.

0
Comment actions Permalink

Hello guys, how can I switch back to the old UI to restore behavior?

0
Comment actions Permalink

> how can I switch back to the old UI to restore behavior?

Settings | Version Control | Commit | Use non-modal commit interface. Can be toggled via Find action.

Also, you can use Switch to Commit dialog option under gear of the Commit toolwindow

0
Comment actions Permalink

I've switched back to the non-modal commit interface. But double clicking still does not open the file, neither does F4 or anything else I've found.

Any other suggestions?

0
Comment actions Permalink

joni

What keymap scheme are you using (File | Settings | Keymap)? Have you tried right-clicking on the file > 'Jump to Source' action?

0

Please sign in to leave a comment.