intellij dose not start and shows "start error"


hi, I have tried opening IntelliJ idea community edition and it showed me the below error, how to overcome this error?

I have tried bisecting the plugins and restarting but it still shows me the same error, until the stage even there are no plugins left in the folder.

Thanks in advance


Internal error. Please refer to

java.lang.NoSuchMethodError: 'com.intellij.ide.plugins.IdeaPluginDescriptorImpl[] com.intellij.ide.plugins.PluginManagerCore.loadDescriptors()'
at com.intellij.idea.MainImpl.start(
at com.intellij.idea.StartupUtil.lambda$startApp$5(
at com.intellij.util.ui.EdtInvocationManager.executeWithCustomManager(
at com.intellij.idea.StartupUtil.startApp(
at com.intellij.idea.StartupUtil.prepareApp(
at com.intellij.ide.plugins.MainRunner.lambda$start$0(
at java.base/

JRE 11.0.6+8-b765.25 amd64 by JetBrains s.r.o

Liubov Melnikova
Comment actions Permalink


Have you updated Intellij through the Toolbox?  It seems to be a known issue then:   If not, see the related question of the bug tracker.

Comment actions Permalink

I had the same error with my IntelliJ 2020.1 installation. I deleted my previous IntelliJ 2019.x installation, removed all the old configurations and installed a new copy. Yet, it still failed to start because of this exception. 

However, if I use a new user and install a new copy in the new user environment of the same Windows 10. It started perfectly.

Comment actions Permalink

I fixed my installation. The previous configurations were copied to a new location to %USERPROFILE%\AppData\Local\JetBrains and %USERPROFILE%\AppData\Roaming\JetBrains which I was not aware of (duh!!!) I was focusing on the old directory locations. I cleared these directories and got it to run with default setup. When I reimport my old configurations the same error returned. I guessed the marketplace plugin was the culprit and deleted %USERPROFILE%\AppData\Roaming\JetBrains\IdeaIC2020.1\plugins\marketplace. When I started it again, IntelliJ was up and running.

Comment actions Permalink

I hit this same issue with OSX Catalina 10.14.6 when I upgraded from PycharmCE2019.3 to 2020.1.  The fix was to remove the ~/Library/Application Support/JetBrains/PyCharmCE2020.1/plugins/marketplace directory and start Pycharm again.  Works fine now.

Comment actions Permalink

Run this commad

rm -rf ~/Library/Application\ Support/JetBrains/IdeaIC2020.1/plugins/marketplace/lib


thanks, Chris


Comment actions Permalink

I got this error when I installed some Markdow plugins. I had to remove the "lib" marketplace plugins folder:

rm -rf ~/.local/share/JetBrains/Toolbox/apps/AndroidStudio/ch-0/201.6719854.plugins/marketplace/lib

I'm using Android Studio 4.1 RC 1 with the Jetbrains Toolbox on Linux (Ubuntu).

Comment actions Permalink

Hi guys,
if your android studio not opening properly after updated.
Just press CTR+H in FileManager (show hidden files). now you can see the .local file.
now go to remove the google file from there. (Path -> local/share/google).

This for Ubuntu users.


Comment actions Permalink

On Ubuntu, I solved this error by running following command,

rm -rf ~/.local/share/Google/AndroidStudio4.1/marketplace/lib
Comment actions Permalink

Read the above comments and found that in order to fix this issue we need to delete the marketplace/lib file of whatever Jetbrains IDE you are using.

On ubuntu find the folder using the following command - 

```sudo find ~/ -iname "marketplace" -type d ```

then delete the the lib folder in the path provided by terminal, in my case

rm -rf /home/suyash/.AndroidStudio4.0/config/plugins/marketplace/lib

Run the ide again and Bingo!! 



Please sign in to leave a comment.