Painfully Slow

PhpStorm gets slower and slower with every update.  On large files (> 5,000 lines) I'm waiting 1-3 seconds between keypresses and mouse clicks.

Please tell me what extra processing you've added to this version so that I can turn it all off - thanks.

3 comments
Comment actions Permalink

Sorry, but unfortunately we can't say for sure what's causing the problem. Nor there's a "turn off useless stuff" button.

It's better to investigate this in a support ticket via Help | Contact Support.

Checking related issues I can see there was a problem with SQL injections. Do you have SQL code fragments in your PHP code?

 

0
Comment actions Permalink

Thanks for replying.  I appreciate there's no magic button, I was just having a rant, but there is a marked difference with this version, and my Macbook Pro isn't particularly old or slow.

I do have LOTS of MySQL queries in strings throughout my PHP, and I definitely don't need PhpStorm to be analysing these.  It is possible to stop PhpStorm from looking for any nested MySQL, HTML, CSS or JavaScript?  The only thing I want it to check is my PHP, nothing else.

0
Comment actions Permalink

@Rich

Disable your Language Injections then so that IDE does not inject those languages into your strings/HEREDOCs and alike.

Start with SQL ones and see if it will improve anything.

Settings/Preferences | Editor | Language Injections

 

P.S. It will do nothing if you use manual injections via PHPDoc style "/** @lang SQL */" or "// language=SQL" inline comments (as these are manual and not automatic injections).

0

Please sign in to leave a comment.