Jetbrains Account Sync


I installed ubuntu and used GoLand on Ubuntu. I used my JetBrains account to activate my license. But when moving back to Windows, I logged into Jetbrains Rider with the same account. Now I can see Ubuntu fonts and layouts in my IDE. I want to use the default one. I tried a lot to do reset but that didn't work. How can I reset the settings and do not get auto sync when using my Jetbrains account with any IDE?  

Official comment


Sorry to hear you are experiencing this issue. Please try disabling settings synchronization as described here:

Does it help?

I disabled but even after uninstalling my Rider, I can see the same fonts in my IDE. How to solve that?


Is it only editor font or also the UI font?

If it is only the editor, use "Restore Defaults" in "Preferences | Editor | Font".

If it is UI also, you can try to fix it manually in "Preferences | Appearance & Behavior | Appearance".

Alternatively, please refer to this documentation page:
Note that this will drop all the settings, so it makes sense to at least backup the directory before removing it.

Before you do all the resets, can you please share the screenshots of your settings in "Preferences | Editor | Font" and "Preferences | Appearance & Behavior | Appearance"? This might help us understand why the fonts have been synced between different operating systems. We have a related bug report here:


Please sign in to leave a comment.