Can't run idea-IU-201.6668.121

Answered

Hi

after updating it today the Idea didn't start. downloaded whole gzip, removed .IntelliJIdea2019.3, still doesn't start. Splash screen appears and then nothing happens. The console like

$ /opt/idea-IU-201.6668.121/bin/idea.sh
/opt/idea-IU-201.6668.121/jbr/bin/java
-Xms512m -Xmx2000m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Dawt.useSystemAAFontSettings=lcd -Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.intellij.util.ReflectionUtil to method sun.java2d.SunGraphicsEnvironment.isUIScaleEnabled()
WARNING: Please consider reporting this to the maintainers of com.intellij.util.ReflectionUtil
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release


that's with -Didea.debugger.trace=ALL - still nothing is logged, .IntelliJIdea2020 folder is not created.

The idea-IU-193.6911.18  starts and works ok.

is there something but idea.debugger.trace to tweak to get more logging?

4 comments
Comment actions Permalink

Does /var/log/syslog or /var/log/messages contain additional information?

Have you tried to clear plugins directory? https://www.jetbrains.com/help/idea/tuning-the-ide.html#plugins-directory

0
Comment actions Permalink

there is

Apr 27 11:42:51 mynotik acvpnagent[2548]: Automatic correction of the routing table has been successful.
Apr 27 11:43:00 mynotik /usr/lib/gdm3/gdm-x-session[3396]: (II) modeset(0): EDID vendor "CMN", prod id 5321
Apr 27 11:43:00 mynotik /usr/lib/gdm3/gdm-x-session[3396]: (II) modeset(0): Printing DDC gathered Modelines:
Apr 27 11:43:00 mynotik /usr/lib/gdm3/gdm-x-session[3396]: (II) modeset(0): Modeline "1920x1080"x0.0 152.84 1920 2000 2060 2250 1080 1086 1094 1132 -hsync -vsync (67.9 kHz eP)
Apr 27 11:43:01 mynotik org.gnome.Shell.desktop[3553]: Window manager warning: Window 0x2a00007 (win0) sets an MWM hint indicating it isn't resizable, but sets min size 1 x 1 and max size 2147483647 x 2147483647; this doesn't make much sense.

in /var/log/syslog (same appears in the log when I run idea-IU-193.6911.18) and it creates

./IntelliJIdea2020.1
./IntelliJIdea2020.1/log
./IntelliJIdea2020.1/tmp
./IntelliJIdea2020.1/index
./IntelliJIdea2020.1/index/stubs
./IntelliJIdea2020.1/index/stubs/.perFileVersion
./IntelliJIdea2020.1/index/stubs/.perFileVersion/indexed_versions
./IntelliJIdea2020.1/index/stubs/.perFileVersion/indexed_versions/indexed_versions.next
./IntelliJIdea2020.1/index/fileincludes
./IntelliJIdea2020.1/index/fileincludes/.perFileVersion
./IntelliJIdea2020.1/index/fileincludes/.perFileVersion/indexed_versions
./IntelliJIdea2020.1/index/fileincludes/.perFileVersion/indexed_versions/indexed_versions.next
./IntelliJIdea2020.1/index/todoindex
./IntelliJIdea2020.1/index/todoindex/.perFileVersion
./IntelliJIdea2020.1/index/todoindex/.perFileVersion/indexed_versions
./IntelliJIdea2020.1/index/todoindex/.perFileVersion/indexed_versions/indexed_versions.next
./IntelliJIdea2020.1/index/hashfragmentindex
./IntelliJIdea2020.1/index/hashfragmentindex/.perFileVersion
./IntelliJIdea2020.1/index/hashfragmentindex/.perFileVersion/indexed_versions
./IntelliJIdea2020.1/index/hashfragmentindex/.perFileVersion/indexed_versions/indexed_versions.next
./IntelliJIdea2020.1/index/idindex
./IntelliJIdea2020.1/index/idindex/.perFileVersion
./IntelliJIdea2020.1/index/idindex/.perFileVersion/indexed_versions
./IntelliJIdea2020.1/index/idindex/.perFileVersion/indexed_versions/indexed_versions.next

in ~/.cache/JetBrains but all are empty. Tried to clean up everything - nothing changed.

+cleaning plugins (removing IntelliJIdea2020.1 from  ~/.local/share/JetBrains)  didn't help either


0
Comment actions Permalink

Don't have ideas on the fly.

Please report at YouTrack with logs and system info attached. Screencast would also speed up the investigation. 

0
Comment actions Permalink

it actually finally worked. I noticed another java process and after killing it 2020 ran ok. The process must have been from first IntelliJIdea2020.1 instance which somehow lost its window but didn't exit.

0

Please sign in to leave a comment.