Test coverage does not update when using remote interpreter

For some odd reason when I am using the remote interpreter to "run test with coverage", it does not update the coverage in PyCharm.

The test runs fine locally and on the remote server with 100% success. When I run locally I can see all the percentages and all the lines that were hit by my test cases but that's not the case when I use remote interpreter.

The only strange thing I found which may be related is that when I debug my tests I get the following error from the debugger:

Couldn't apply path mapping to the remote file. /app/user/home/myuser/myproject/app/tests/test_rules.py can't be found in project. You can continue debugging, but without the source. To fix that you can do one of the following:

Edit settings of path mapping in remote debug configuration

Auto-detect path mapping settings

Download source from remote host

 

This does not happen when I debug my code. I have checked all the settings under the Deployment settings page and the mapping configuration seems to be correct and working fine with the rest of the project for normal debugging.

 

Any idea why this is happening and how I can get it fixed? 

 

 

 

 

3 comments
Comment actions Permalink

Hello,

 

Any insights to this problem? 

I experience it when I try to step in to a installed python package.

0
Comment actions Permalink

Hi, the issue did not reproduce for me - the coverage appears to be working fine with the SSH interpreter.

Are you using bundled coverage option from **Preferences | Build, Execution, Deployment | Coverage** ?

Does the issue reproduce if you test it in a new minimal project?

0
Comment actions Permalink

Well, I was able to figure out the issue. This was a long time ago, so I try my best to remember what happened. One of the project path values was through a shortcut and that was causing the issue. Sorry, do not remember the details.

0

Please sign in to leave a comment.