5 comments
Comment actions Permalink

do you have any watchers configured (in the IDE, or outside it) that run and generate files on save? If yes, does excluding the target folders where the generated files are stored from indexing make things any better?

0
Comment actions Permalink

Elena Pogorelova I don't. I've also tried invalidating my cache and restarting. Nothing changes.

0
Comment actions Permalink

Please try disabling Synchronize files on frame activation (Preferences | Appearance & Behavior| System settings) - does it make things any better?

0
Comment actions Permalink

Elena Pogorelova While it might of helped a tiny bit (I can't tell), there is still a considerable lag.

0
Comment actions Permalink

Your dumps mostly show activities related to files synchronization. Plus the issue description (problems on saving, better performance after disabling VFS auto-refresh) suggests that the issue is related to indexing that is started on saving. Are you sure that you have excluded all auto-generated stuff from indexing?

0

Please sign in to leave a comment.