CLion 2020.1 becomes unusable when typing in editor

Completed

I've been using CLion for years without issue and today, a mere hour ago, the IDE began using 300%+ CPU when I type into the editor (along with clangd at 100% CPU). This makes the IDE unusable! I'm running this on a MacBook Pro and I've tried several things suggested to help in other threads, those include:

  • Disabling Clangd
  • Disabling C/C++ inspections: Data flow analysis, Unused Code and General | Simplifiable statement
  • Invalidate/clear cache
  • Rebooting

Needless to say none of this changed the situation in the slightest so I re-enabled all of these features.

I welcome any suggestions, tips and especially fixes... thanks.

5 comments
Comment actions Permalink

Hello!

Sorry for the inconvenience. Please capture a CPU snapshot while reproducing the issue and send it to clion-support at jetbrains.com.

0
Comment actions Permalink

Greetings, I also created an issue over here: https://youtrack.jetbrains.com/issue/CPP-20269 and posted the snapshot and log there. Can you access that or is it redundant for me to have the issue posted in both places? Thanks!

0
Comment actions Permalink

Thanks for creating the issue and providing the materials! I see that the issue is already assigned to the responsible developer, he will investigate the snapshot. No need to send it to clion-support at jetbrains.com. 

0
Comment actions Permalink

Is there any more information or a fix for this? 

0
Comment actions Permalink

Mjudd220 The important thing is that performance issues which even look the same to users might be caused by completely different reasons. Therefore each case requires a detailed investigation and additional information provided by the user.

Please capture a CPU snapshot while reproducing the issue and send it to clion-support at jetbrains.com.

0

Please sign in to leave a comment.