ESLint path invalid when going from PC to Mac

I frequently code on my mac (laptop) and on my desktop. Everything works really well except for the lint path which i have to edit every time i startup again on my macbook pro having worked on my desktop the previous time. It basically contains the absolute path to eslint on my desktop. Why can't I store it as a relative path? I can put ~ in the path and it understands it fine, but is obviously saved as an absolute path.

I found a similar ask 3 years ago - and WEB-17213 was raised. But it appears to be still at the submitted state?  Is there any alternative?

 

Thanks!

2 comments
Comment actions Permalink

it's still an issue unfortunately, please vote for https://youtrack.jetbrains.com/issue/WEB-17213 to increase its priority and get notifications on updates

0
Comment actions Permalink

Is that a project specific path to the linter (e.g. PROJECT_ROOT/node_modules...) or a global/system wide one? WEB-17213 mentions local ones (project specific paths)

For global, maybe custom Path Variables would work there (they work transparently: you always see the full path in IDE but it's stored differently in the config file)? Try it: make some variable on one of the OS (e.g. Windows) and point it to the linter root folder. Then update the path to the linter, save Settings and exit IDE. Now just check how it's saved in the project config files (the PROJECT_ROOT/.idea subfolder).

If it works, create the same variable with local path on your Mac and then open that project.

0

Please sign in to leave a comment.