Can't run MSSQL queries with version 2020.1.4

Answered

DataGrip 2020.1.4
Build #DB-201.7846.70, built on May 28, 2020

Title.

 

Queries just give an error with "." and is not very useful.

14 comments
Comment actions Permalink

While we are fixing the issue, please install plugin 'Choose Runtime', restart IDE, to open the Choose Runtime dialog, invoke Search Everywhere (press Shift twice) or Find Action (Ctrl + Shift + A or Cmd + Shift + A) and search for Choose Runtime. Then select jbrsdk-11_0_6-windows-x64-b722.2 and install it. after please go to C:\Users\current_user\AppData\Roaming\JetBrains\DataGrip2020.1\jdks\jbrsdk-11_0_6-windows-x64-b722.2\jbrsdk\bin and put there dll from https://mvnrepository.com/artifact/com.microsoft.sqlserver/mssql-jdbc_auth/8.2.2.x64 and test connection.

0
Comment actions Permalink

This fixed it, but what a pain! This was a really big screw up by you guys!

1
Comment actions Permalink

Yeah I have to agree. Something as basic as running a query and somehow that made it past your testing prior to release?

4
Comment actions Permalink

I just had the same issue after the upgrade today - usually JB are pretty good - this is a first. Luckily I also use Toad.

0
Comment actions Permalink

Yuriy Vinogradov: do your instructions work for the jDts driver? I am using the jDts driver not the Microsoft one, and I want to keep it this way.

Also is there another way to fix this other than installing yet another JDK?

0
Comment actions Permalink

And a follow-up question: Will the fix restore the correct runtime once it's released, or are we going to need to go back in and change the runtime back?

2
Comment actions Permalink

If changing runtimes (and getting the linked DLL into C:\Users\current_user\AppData\Roaming\JetBrains\DataGrip2020.1\jdks\jbrsdk-11_0_6-windows-x64-b722.2\jbrsdk\bin) didn't resolve the issue, what is the next step? Am I out of luck with 2020.1.4 if I'm still running Windows 7?

0
Comment actions Permalink

Bogc it should work also for bundled jTds. I have never tested it for any third-party drivers.

SQL_Greg_80 you need to change it to latest version manually

Galen Helgemo Do you run 32-bit version?

0
Comment actions Permalink

I downgraded to 2020.1.3 - I am going to wait until JB provides a proper fix. It was painless - the previous downloads are available (I had to log in under my account).

0
Comment actions Permalink

Yuriy Vinogradov I should be running x64

DataGrip 2020.1.4
Build #DB-201.7846.70, built on May 28, 2020

Runtime version: 11.0.6+8-b722.2 amd64 (this wasn't correct until I re-followed the steps you outlined above, but still didn't change the result)
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 7 6.1

0
Comment actions Permalink

This is a concerning issue to have happen while trying to work, though I appreciate the workaround which did resolve the issue.

I have the same question as SQL_Greg_80 -- once the permanent fix is released, do we simply uninstall Choose Runtime to start using the latest runtime again? How to we avoid having to manually change runtimes going forward.

Is there any release estimate for the permanent fix?

1
Comment actions Permalink

Jonathon You will need to run "Choose runtime" again and select "use default". The fix will be available soon.

0
Comment actions Permalink

Is this really not resolved yet? It's so bad that you should have completely rolled back the version and deployed that as an update.

You are making my decision to NOT renew this product very easy. I'll be sure to let your Sales team know why.

1
Comment actions Permalink

I am surprised they didn't fix it by now. But to be fair, this is the first time in 10+ years since I've been using JB products that I experience a bug of this magnitude. I am willing to cut them some slack :-)

Kevin, I agree that release 2020.1.4 should not have been made available as an update. I wonder, if 2020.1.5 comes out, will I see that in the updates?

0

Please sign in to leave a comment.