Why Emmet doesn't work without ')' inside of { (stuff) } block?

WebStorm 2020.1.2. Emmet.

If I write p{You can find useful site }>a[href="http://emmet.io"]{here}+{ (Emmet tool)} 


p{You can find useful site }>a[href="http://emmet.io"]{here}+{ \(Emmet tool\)} 

then when I press TAB key I get the result:

<p>You can find useful site <a href="http://emmet.io">here</a> (Emmet tool)</p>

It is expected result. Pay attention: I need to use parentheses as part of my text.

But if I delete the ) char or \) then Emmet do nothing (WebStorm IDE). Why does it happen?


Not sure I follow you... If I enter

p{You can find useful site }>a[href="http://emmet.io"]{here}+{Emmet tool}

in .html and then hit Tab, Emmet works as expected:

<p>You can find useful site <a href="http://emmet.io">here</a>Emmet tool</p>

I don't need adding any parentheses


I want "Emmet tool" text would be bounded by parentheses. I get it with \( and \). But if I don't write \) then Emmet doesn't work. I.e. I can't to get the "(Emmet tool" text.


Emmet itself works in exactly same way - try entering

p{You can find useful site }>a[href="http://emmet.io"]{here}+{(Emmet tool}

in the Emmet playground at https://docs.emmet.io/abbreviations/syntax/#notes-on-abbreviation-formatting (press Try it yourself, enter abbreviation and hit Tab)


tried this in VSCode - same result:


Please sign in to leave a comment.