What's the smart commands execution



I can't understand the feat.how to do ? it's for what?




I wonder how many people actually find this feature useful. I never found it intuitive at all; I tried using it several times before completely disabling it, but (1) I found it so confusing and (2) it was the most annoying thing. I clicked turn off at least 100 times, before I changed the .idea settings file to fully disable it.


Arina Efremova


Yes, I've seen the comments. You want me to go in and disable some global settings that I will forget about at some point. No thanks. Why don't you guys just fix the bug?



If you wish for the recurring 'Got it' balloon to go away, try restarting the IDE using the File | Invalidate Caches & Restart option.

If you wish to disable the smart command handling feature globally instead of doing it project by project, you can either install IDEA version 2020.2 EAP where this usability problem is fixed, or use the 'disable the registry setting' workaround in every other version prior to that.


For Django, I typed '$ python manage.py _' and pressed Ctrl-Enter on my mac but nothing happened. Is it a bug or am I doing it wrong? 


It is little things like this that make or break a tool.  Intellij's awesomeness comes from being simple to use.  An annoying popup that motivates individuals to spend so much time to "get relief" clearly breaks that principle.  There are many tools I personally have stopped using for this type of reason (Eclipse being one of them).

Please don't popup in our faces unless it is *really* important.  A once-and-done "hey, here's a feature" popup can be forgiven, IF it is truly only once.  Even then, I really wish it were not covering the work I am trying to do in that moment.  Seriously, this is like a 2 year old jumping in my face while I'm on a Zoom call.

Please fix this.  Simple fix, significantly happier users.  Win, win, win win win. :)




What is the version of your IDE?

Was the command highlighted green when you typed it?

Are you able to run the same command from the Run Anything pop-up (double-Ctrl)?


Yes, that is a most-welcome setting, thank you for pointing it out. Now, please Please! make that much easier for the user to set.  When I clicked "Got it" the first time, I expected to be done with it.  Still would have preferred not to have it happen in the first place.

With all that said, again thank you for pointing that out for me!


I tried CTRL+Enter with every Django command and nothing happens. But if it prompts me to CTRL+Enter on every Django command then it means that there is something that this thing can do. So it's just me who is too stupid to figure out how this feature works. At least that's what PyCharm is passively aggressively implying. 

Thank you JetBrains for keeping me humble!


I like it. It's a new feature and might need some work (based on previous comments), but what a cool idea.




Hi ruslani - can you provide an example please? Preferably with a screenshot.

Also, what is the version of your PyCharm?


Hi Arina. I've tried both Ctrl-Enter and double-Ctrl for the four commands below but nothing happened. My IDE version is PyCharm 2020.1.4 (Professional Edition) Build #PY-201.8743.11, built on July 21, 2020.


Alvin, ruslani

The 'smart command' feature was enabled for the whole IntelliJ platform at some point, but not all JetBrains IDEs fully support the functionality at the moment. PyCharm is one of them. You can see highlighting in the terminal for recognized commands, but the actual command handling mechanisms are not yet enabled.

In order to eliminate the confusion, the feature was disabled completely in version 2020.2. For now.


I like new feature.

Thank you!


Please sign in to leave a comment.