What's the smart commands execution

Answered

 

I can't understand the feat.how to do ? it's for what?

 

 

46 comments
Comment actions Permalink

Shift-Shift > type "registry" and hit Enter to open the Registry window. Start typing to find the following option and disable it:

terminal.shell.command.handling

14
Comment actions Permalink

Is there a way to disable this thing?  It is *super* annoying. I know I can disable it per project, but it's a lot of clicking. I'd like it *gone* and never show it's popup again.

11
Comment actions Permalink

Super annoying the first 1,000 times I clicked the "got it" link.
After that, serious concerns re the lack of usability testing in IJ products...

10
Comment actions Permalink

I totally hate this feature....  

9
Comment actions Permalink

Super super annoying.  I realise a few people have said that already ... but just in case it helps to raise awareness of just how super super super annoying this is !!!

8
Comment actions Permalink

For me I have 100's of projects. Turning it off per project is just really super super super annoying !!!!   My thought is that it should be really easy to turn it off globally ... (and without that it is a massive pain for people like me).   

:)

4
Comment actions Permalink

I'm bumping the fact that this is super annoying.

4
Comment actions Permalink

This feature should be opt-in.  It causes node apps started in terminal to crash randomly and it is extremely difficult to identify why.  Turning this feature off stops the random crashing.  

3
Comment actions Permalink

I see, thank you, this feature is still unstable

2
Comment actions Permalink

I feel like i see it the first time i use the terminal for every session.  I would have expected it to stop, after the first "got it".  It's a global feature, so dismissing it once should persist.  It's not like people need to be reminded every project and especially not every session, if they've dismissed the popup.

2
Comment actions Permalink

Arina Efremova :
1) Yes, clicking "I got it" had no effect at all, I'd get still get the warning every time I opened a new IDE session.

2) I have not seen it since setting  terminal.shell.command.handling=false    

3) that setting seemed to work across all IDEs with synced settings, ie: looks like I only had to set it once.

4) suggestion: the popup should have a button or link to turn off the shell command handling.

5) there should be some documentation explaining what this feature actually does, who knows, it might actually be a useful feature!

2
Comment actions Permalink

I use ZSH with a lot of plug-ins and this "smart terminal" messes up half of them. This feature appears out of nowhere, it's mega annoying, and with every project it starts again. I probably wouldn't pay attention to this if I could turn it off once for all projects, but now it clearly aspires to IntelliJ's most annoying feature

2
Comment actions Permalink

And yes, this is not a feature it is a bug. It is bugging me and apparently I'm not the only one. It is more than annoying. Remove this crap.

2
Comment actions Permalink

I wonder how many people actually find this feature useful. I never found it intuitive at all; I tried using it several times before completely disabling it, but (1) I found it so confusing and (2) it was the most annoying thing. I clicked turn off at least 100 times, before I changed the .idea settings file to fully disable it.

2
Comment actions Permalink

Smart execution of Terminal commands was introduced to allow for launching a UI after parsing commands instead of showing console output.

 

Once an input command is matched, it is highlighted, and then by pressing Ctrl-Enter you can open a corresponding UI with parameters fetched from the command.

 

For example, `git log --author=john` opens the Git Log panel filtered by users that match "john", while `git log branch` opens the Git Log tab with the specified branch.

 

The feature is experimental at the moment, and full documentation for it is under way.

1
Comment actions Permalink

Wow... Thank you so much!  :)  You've made my day.

1
Comment actions Permalink

David Moshal, Rob Bygrave

Are you saying that you get the pop-up every time you open your projects, even if you clicked the "Got it" link before? Is it gone for you if you disable the feature under File | Settings | Tools | Terminal?

1
Comment actions Permalink

Rob Bygrave, I submitted a request for this: IDEA-243824. Feel free to vote for it and add your comments there.

1
Comment actions Permalink

Arina Efremova that did seem to stop the prompt.  Just highlights green now, which is fine.  Thanks

1
Comment actions Permalink

Rob Bygrave you can turn off the feat globally

 

registry =>

terminal.shell.command.handling

 

I tried,it works

0
Comment actions Permalink

Alan He You can't.

If you open another project then this setting will turn on again.

0
Comment actions Permalink

Arina Efremova thanks. BTW I also use ZSH, not sure if that's relevant though.

0
Comment actions Permalink

Łukasz Sitarski you are right, I have updated the answer, the registry setting works.

0
Comment actions Permalink

Arina Efremova the link on your last comment is wrong!

0
Comment actions Permalink

Elin Yordanov - Thank you, fixed the link.

 

Per IDEA-243824, the issue in question is dealt with in the latest 2020.2 EAP version. Starting with build 202.6109.22, the setting under File | Settings | Tools | Terminal will be global (set per application).

The notification balloon with the 'Got it' link will remain, but will be redesigned to make this link an actual action (IDEA-244065).

0
Comment actions Permalink

All,

A blog post was published today describing how to run IntelliJ IDEA features from the terminal utilizing the Smart Command Handling functionality. Feel free to check it out and leave your comments / questions in the post's thread.

0
Comment actions Permalink

Wow, this pop up bubble is the most annoying thing ever. I've pressed "got it" at least a few hundred times now and it still pops up every time. How do you turn this off????

0
Comment actions Permalink

Arina Efremova

 

Yes, I've seen the comments. You want me to go in and disable some global settings that I will forget about at some point. No thanks. Why don't you guys just fix the bug?

0
Comment actions Permalink

Marc

If you wish for the recurring 'Got it' balloon to go away, try restarting the IDE using the File | Invalidate Caches & Restart option.

If you wish to disable the smart command handling feature globally instead of doing it project by project, you can either install IDEA version 2020.2 EAP where this usability problem is fixed, or use the 'disable the registry setting' workaround in every other version prior to that.

0

Please sign in to leave a comment.