IntelliJ 2020.1.2: Consistently crashes on macOS Catalina after long laptop sleep


For the last week or so, IntelliJ 2020.1.2 consistently crashes each night/morning on my MacBook Pro 2018.

  • I'm up-to-date on both macOS (10.15.5) and IntelliJ (2020.1.2 Ultimate, Build #IU-201.7846.76).
  • The crash is always in "22 Java: Java2D Queue Flusher".
  • I'm running IntelliJ with a Jetbrains OpenJDK 11: Runtime version: 11.0.7+10-b765.53 x86_64, VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
  • The crash also happened with an earlier version of the Jetbrains OpenJDK 11.
  • IntelliJ doesn't seem to crash throughout the day when my Mac sleeps for an hour or two at most. But it is crashed nearly every morning when the Mac wakes up after 6-8 hours.

I've been using IntelliJ daily for years now. These crashes only started recently. I suppose it could be caused by either the latest macOS version or the latest IntelliJ one.

Does anybody know how to fix this?

Here are the details on the crashed thread from the macOS log:

Thread 22 Crashed:: Java: Java2D Queue Flusher

0   libsystem_kernel.dylib         0x00007fff6b44d33a __pthread_kill + 10
1   libsystem_pthread.dylib       0x00007fff6b509e60 pthread_kill + 430
2   libsystem_c.dylib             0x00007fff6b3d4808 abort + 120
3   libGPUSupportMercury.dylib     0x00007fff527250a5 gpusGenerateCrashLog.cold.1 + 95
4   libGPUSupportMercury.dylib     0x00007fff5271c18f gpusGenerateCrashLog + 89
5 0x00000001198f4241 gpusKillClientExt + 9
6   libGPUSupportMercury.dylib     0x00007fff5271d55b gpusSubmitDataBuffers + 164
7 0x00000001198cedc7 glrATI_Hwl_SubmitPacketsWithToken + 91
8 0x00000001198fb594 glrWriteTextureData + 3080
9   GLEngine                       0x00007fff3be292f1 glTexSubImage2D_Exec + 1557
10  libGL.dylib                   0x00007fff3b1b52ae glTexSubImage2D + 55
11  libawt_lwawt.dylib             0x0000000116a28e8a OGLVertexCache_AddMaskQuad + 249
12  libawt_lwawt.dylib             0x0000000116a232a1 OGLMaskFill_MaskFill + 230
13  libawt_lwawt.dylib             0x0000000116a249d3 Java_sun_java2d_opengl_OGLRenderQueue_flushBuffer + 1947
14  ???                           0x0000000122cc177d 0 + 4878767997
15  ???                           0x0000000124192c90 0 + 4900596880

Here's more on my configuration:

IntelliJ memory: 2048 MB
Custom properties:



Custom VM options:


Comment actions Permalink

Seems similar to

May you describe the project you are working on? Which language is in use, how many files? 

Do you have a possibility to check if this is reproduced with a sample "hello world!" project?

Comment actions Permalink

The only open project is a Gradle Spring Boot project with Java 11 and an Angular app inside. I've worked with this project since February, but the crashes only showed up about a week ago. Both Gradle and Java last changed maybe two or three weeks ago.

What I'll do tonight is that I create a similar, sample Gradle Spring Boot project with Java 11. I'll then have only this sample project open and see if IntelliJ crashes with it, too.

Comment actions Permalink

Follow this thread for updates:

We are working on finding the root cause. 


Comment actions Permalink

Just my luck:

  • After about 4 hours of sleep, IntelliJ did crush again with my regular project. Because of display issues, I had to restart my Mac afterwards.
  • After about 7 hours of sleep, IntelliJ didn't crush with my sample project.

I'll try again tonight.

Comment actions Permalink

Tonight it worked - IntelliJ crashed with sample project. I logged the details in the issue.

Comment actions Permalink

I discovered this post while researching this similar GPU crash in Safari:

Application Specific Signatures:

Graphics kernel error: 0xfffffffc

Thread 0 Crashed:: Dispatch queue:

0   libsystem_kernel.dylib         0x00007fff6f62733a __pthread_kill + 10

1   libsystem_pthread.dylib       0x00007fff6f6e3e60 pthread_kill + 430

2   libsystem_c.dylib             0x00007fff6f5ae808 abort + 120

3   libGPUSupportMercury.dylib     0x00007fff568b50a5 gpusGenerateCrashLog.cold.1 + 95

4   libGPUSupportMercury.dylib     0x00007fff568ac18f gpusGenerateCrashLog + 89

5 0x0000000146a41241 gpusKillClientExt + 9

6   libGPUSupportMercury.dylib     0x00007fff568ad55b gpusSubmitDataBuffers + 164

7 0x0000000146a1bdc7 glrATI_Hwl_SubmitPacketsWithToken + 91

8             0x00007fff45951e65 WebCore::GraphicsContext3D::reshape(int, int) + 1573

9             0x00007fff4551b09f WebCore::WebGLRenderingContextBase::initializeNewContext() + 3487

10             0x00007fff4550b0fc WebCore::WebGLRenderingContextBase::WebGLRenderingContextBase(WebCore::CanvasBase&, WTF::Ref<WebCore::GraphicsContext3D, WTF::DumbPtrTraits<WebCore::GraphicsContext3D> >&&, WebCore::GraphicsContext3DAttributes) + 2492

11             0x00007fff45518d8b WebCore::WebGLRenderingContextBase::create(WebCore::CanvasBase&, WebCore::GraphicsContext3DAttributes&, WTF::String const&) + 2971

12             0x00007fff453e1387 WebCore::HTMLCanvasElement::getContext(JSC::JSGlobalObject&, WTF::String const&, WTF::Vector<JSC::Strong<JSC::Unknown, (JSC::ShouldStrongDestructorGrabLock)0>, 0ul, WTF::CrashOnOverflow, 16ul, WTF::FastMalloc>&&) + 919

13             0x00007fff44573050 WebCore::jsHTMLCanvasElementPrototypeFunctionGetContext(JSC::JSGlobalObject*, JSC::CallFrame*) + 608
Comment actions Permalink

Please update macOS to 10.15.6 where the issue has been fixed. 

Comment actions Permalink

IntelliJ keeps crashing even after 10.15.6 updates. The IntelliJ Ultimate doesn't open any window after it starts!!!!

Comment actions Permalink

Replied to you other post, please report to YouTrack with the crash dumps attached.

Comment actions Permalink

I have the same problem and seriously dampens my productivity. Started to happen after a MacOS update. Will move on to some other simpler IDE until this is not resolved.

PyCharm 2020.2

Comment actions Permalink

Ervin BosenbacherThis crash has been resolved in macOS 10.15.6 update. Please raise a new issue at, and attach crash dumps along with the information about your system environment.


Please sign in to leave a comment.