Can't browse Docker files for some containers?

I've encountered two containers, so far, which PhpStorm can't access via the container's Files tab. I'm wondering if I'm overlooking a setting or something...


The two containers are nginx:1.19-alpine and wordpress:5.1.1-fpm-alpine.


Tried these images with the same result and nothing interesting in the IDE logs.

However, I have managed to find out that "php:7.2-apache" is browsable, so this option should work in general.


Not sure what "kind of container" is not supported but here is the similar (fixed) report: 

Probably, it worth submitting another report with the list on "non-working" images.


One similarity between the non-working containers is that they use “sh” instead of “bash” shell.


Then it's definitely worth submitting a new one. We are not really sure why would browsing containers files would rely on Bash, as Docker integration is developed in the platform, so could you please submit this request to the IDEA tracker?


I have the same issue...

  • Ubuntu: 20.04
  • WebStorm: 2021.1
  • Container: node:14-alpine 

Could you please submit this to our bug tracker?

The problem should be looked into by a corresponding development team.


having the same problem.

  • macOs Big Sur: 11.2.2
  • WebStorm: 2021.1
  • Container: node:12-alpine

Looks like this is Feel free to vote for or comment it in order to get notified about its updates. 


Please sign in to leave a comment.