What *exactly* does "Configure Kotlin" mean?

I just tried to convert a java file using Code->Convert Java File to Kotlin File and got series of messages, the first telling me to "Configure Kotlin", and offering me a choice to "Configure Kotlin in Project " which just leads to a pop-up telling me "There are no configurators available".

However, Tools->Kotlin->Configure Kotlin in Project then tells me "All modules with Kotlin have been configured".

This is a brand new (as in, minutes old) project generated by IntJ with a Kotlin DSL gradle script that is mostly unchanged:

plugins {
kotlin("jvm") version "1.3.72"
}

repositories { mavenCentral() }

dependencies {
implementation(kotlin("stdlib-jdk8"))
}

sourceSets["main"].java.srcDir("src")

tasks {
compileKotlin {
kotlinOptions.jvmTarget = "1.8"
}
compileTestKotlin {
kotlinOptions.jvmTarget = "1.8"
}
}

All I've done there is tweak the default source path.  I then placed a handful of kotlin files there and one in java, which I tried to convert but learned kotlin is not configured for the project, but asking the IDE to help "Configure Kotlin in Project" tells me it is already done o_O?

Everything including the java file (which, if it matters, is in the same directory as the kotlin sources) builds fine both in the IDE and via CLI gradlew.  I have used java -> kotlin conversion before without any hitches, dunno what the choking is about now.

2 comments
Comment actions Permalink
Official comment

Hello. I have played with a few different project configurations, but failed to reproduce the issue. Can you please create an issue at http://kotl.in/issue with a sample project and IDE logs attached.

Comment actions Permalink

For me, performing sync in build tab helped me, because Kotlin was configured, but not downloaded.

0

Please sign in to leave a comment.