Restart button doesn't appear after installed a custom plugin in IntelliJ 2020.1

Answered

I'm currently updating my plugin in order to match the latest IntelliJ IDEA 2020.1 version. But when I build and do a fresh install for 2020.1 it does not show the Restart button. 

https://www.jetbrains.org/intellij/sdk/docs/basics/plugin_structure/dynamic_plugins.html

As mentioned in the above link, I updated my plugin.xml with <idea-plugin restart-required="true"> code but still, the issue is the same. But when trying to update the existing plugin with the new plugin version, it shows the Restart button. 

 

Please let me know, what I'm missing here. 

4 comments
Comment actions Permalink

There seems to be a typo in docs - the key should be "require-restart".

0
Comment actions Permalink

Hi Aleksey,

Thanks for your information. I tried with bellow different implementation, but still, the same issue exists.

1. <idea-plugin require-restart="true">
2. <idea-plugin require-restart="restart-required">
3. <idea-plugin restart-required="require-restart">

Please let me know, what needs to be changed in the implementation.

0
Comment actions Permalink

It should be the first. Ex: https://github.com/JetBrains/intellij-community/blob/master/plugins/devkit/devkit-java-tests/testData/codeInsight/pluginWithModules.xml#L1
Which version of IDE do you use to test? The flag is supported since 2020.1.2 release (builds 201.7846+).

1
Comment actions Permalink

Thanks a lot, Aleksey. Yes, it works. I was testing on the 2020.1.1 version, once I updated it to 2020.1.2 version it worked as expected. 

0

Please sign in to leave a comment.