How do you switch toolchains in clion 2020.1.1?


In the past, when I set up multiple toolchains for the same project I am able to switch between them using the run configuration feature top right. However, it seems to ave disappeared in version 2020.1.1 and the only way I can switch compilers is by modifying the ordering of the toolchains in the list. 

Is there another easier way to switch to a different toolchain? 


Here is a screedump. Note that I have three compilers configured but only the MinGW one is available for selection in the run configurations. 




It seems other profiles were not loaded correctly. Please update CLion to 2020.1.2 and after that call `Tools | CMake | Reset Cache and Reload Project`. Does it help?


Hi Anna, 

Unfortunately no this hasn't worked. I have updated to 2020.1.2, tried invalidating the cmake caches and tried "invalidate cache and restart" (under File). The other toolchains do not seem to be loading.

The only way I can change tool chains is by deleting the profiles of the ones I do not want to use.



Please call `Tools | CMake | Reset Cache and Reload Project` once again and after that send the idea.log file (`Help | Show Log in ...`) to clion-support at Note that logs might contain private user's information (like file paths and names).  


I'm not sure what I've done differently today compared to yesterday but it seems to be working now. When (if?) the problem happens again, I'll do what you suggest and send you the logs (minus personal info). 

Thanks for the help, 



Please sign in to leave a comment.