Commit dialog misfire


When I enter Cmd+K to commit code, the commit dialog comes up fine. I deselect everything, then select the things I want to commit, edit the message, and click Commit. Nothing happens. I click again. Nothing happens. I click several times. Sometimes a small dialog pops in front then disappears, faster than I can try to read what it says. I try unchecking "Perform Code Analysis"; sometimes that seems to help, and then it doesn't. I tried invalidating cache and restart, which seemed to help for a couple of commits, and then it was back to being unresponsive. The last time, to get the button to work, I just clicked it as many times as I could as fast as I could until it finally worked.

PyCharm 2020.1.1 (Professional Edition)
Build #PY-201.7223.92, built on April 29, 2020
Runtime version: 11.0.6+8-b765.40 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1979M
Cores: 12 (this is including hyperthreading)
Non-Bundled Plugins: awesome.console, com.alayouni.ansiHighlight, com.intellij.ideolog, org.intellij.plugins.hcl, com.neon.intellij.plugins.gitlab, mobi.hsz.idea.gitignore, net.seesharpsoft.intellij.plugins.csv, nl.rubensten.texifyidea, BashSupport, amailp.intellij.robot, aws.toolkit, net.ashald.envfile,, ru.adelf.idea.dotenv, ru.meanmail.plugin.requirements, com.intellij.kubernetes, org.toml.lang,



I haven't tried installing the latest version, but I checked the release notes for the latest version, and didn't see anything related to this dialog. I'm in the middle of trying to get something done, and don't have time to install the latest in the event something gets messed up. Is there is an easy fix? Is this fixed in the latest version? Is there a known issue with one of my plugins, or my settings? I do have pre-commit configured to run flake8, and used to have black configured to run as a pre-commit hook as well, but it didn't play nicely with PyCharm's auto-reformatting, so I chose PyCharm's less opinionated formatting and disabled black (I love single quotes and I won't give them up for an auto-reformatter). I'd attach a screenshot of the dialog that flashes after clicking the commit button, but it happens too fast; there's no way I could get it in time.

Thanks for your help,



Please sign in to leave a comment.