A suggestion icon disturbs and prevents normal workflow.


Hi Team,

Could you please advice: each time I edit source code, this suggestion icon (lamp) blocks me if I need put cursor at the begging of the line.

Is it possible to disable the icon appearance? Let's say if I do not press a dedicated key - I do not see the lamp.


Comment actions Permalink

Kostyantyn Krakovych,

Go to `Preferences > Editor > Intentions`:


You can read more about intentions in DataGrip documentation

Comment actions Permalink

vasily chernov


Thank you for the advice.


Please sign in to leave a comment.