Very nitpicky, but how do I get a newline to always start with 4 spaces?

I keep getting incosistent behavior when I press Enter after typing `select` to write the columns I want to select. I'd like it so that if whenever I press Enter after `select`, the cursor goes to the 4th character of the new line.

If starting from a blank query, I first type `select` then press Enter, cursor goes to the 1st character of the newline. If I press Tab, cursor is moved 4 spaces. Then if I type in a column and a comma and press Enter, cursor is set to the 6th character of the newline. This is slowly making me irritated since I'd like to set this the same.

 

Similarly, if I have a query written out, set my cursor right after `Select` then press Enter, the cursor moves to the new line at the 6th character.

 

I've tried changing the setting at Editor > Code Style > SQL > General but that has made this more confusing with more differences

1 comment
Comment actions Permalink

Did you try `Tabs and Indents`?

0

Please sign in to leave a comment.