"This driver is not configured for integrated authentication" error when using SQL Server with Windows authentication

Answered

Hello--I'm using DataGrip 2020.1.5 on Windows 10. A few weeks ago I encountered this issue. After upgrading to 2020.1.5, I am now getting a new issue:

I am using Windows authentication with SQL Server. This is a screenshot of my connection properties:

I have not changed anything under the Advanced tab, nor would I even know what to change. Any ideas of what needs to be configured?

3 comments
Comment actions Permalink

please update driver - open data source properties again and you'll be prompted to download missing driver files.

0
Comment actions Permalink

Yuriy Vinogradov That fixed it. Thanks!

0
Comment actions Permalink

I run into the same issue today, but I had downloaded driver files. What fixed it for me was to switch back to an older version (from 8.2.2 back to 7.4.1). Not sure if this is a product or a driver bug.

From what I recall IJ had suggested to use the more recent driver before it stopped functioning.

I'd be happy to share more details if needed (also using the yt ticket system if needed).

0

Please sign in to leave a comment.