CamelCase Json Tags Is Not Working


I have followed this post and checked out other ones like here and checked out two docs pages.


No matter what I did json tags are always snake case rather than camel case. I also tried to add the same expression as default value but nothing helps.


I'm using 2020.1.3; any one has any idea how to fix this? It is really tiresome to write things manually.




I tried to reproduce the described situation, and I could not do it.

Have you definitely changed two Live Templates to this value (Settings | Editor | Live Templates | Go Struct Tags | JSON and Settings | Editor | Live Templates | Go | JSON)?

It is possible that you are using one template, but you have changed another before.


Daniil thank you, I just fired up my IDE and it is working now. Any chance this might be a cache issue?


These settings should change on the fly, but it is possible that it could be a line cache or something similar.

Should you have any questions, please feel free to let me know.


Please sign in to leave a comment.