Set Javascript version for js.twig files

Hi,

I'm having a bit of trouble with .js.twig files, it seems that they are not using ECMA6+ (when it's the version set in the settings for Javascript).

For example, on optional parameters, I get ", or ) expected", and on the null coalescing operator, "expression expected". I don't get those in .js files, but if the version for .js.twig has to be configured separately from the one for .js file, I can't find where.

Thanks by advance for your help :)

Please sign in to leave a comment.